2

We are in the process of migrating to Drupal 9, and I am having nothing but problems with composer and trying to get Drupal core updated.

I have provided my composer.json file, and a HUGE list of errors it's spitting out at me, and I have absolutely no idea how to fix it.

The command I have been running is composer update


Gathering patches for root package.
No patches supplied.
Loading composer repositories with package information
Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - drupal/core 8.0.0-beta6 requires doctrine/common dev-master#a45d110f71c323e29f41eb0696fa230e3fa1b1b5 -> no matching package found.
    - remove drupal/admin_menu 3.x-dev|keep drupal/admin_menu dev-3.x
    - Conclusion: remove drupal/admin_menu dev-3.x
    - drupal/core-recommended 9.2.6 requires drupal/core 9.2.6 -> satisfiable by drupal/core[9.2.6].
    - Conclusion: don't install drupal/core 9.2.6
    - drupal/core-recommended 9.2.5 requires drupal/core 9.2.5 -> satisfiable by drupal/core[9.2.5].
    - Conclusion: don't install drupal/core 9.2.5
    - drupal/core-recommended 9.2.4 requires drupal/core 9.2.4 -> satisfiable by drupal/core[9.2.4].
    - Conclusion: don't install drupal/core 9.2.4
    - drupal/core-recommended 9.2.3 requires drupal/core 9.2.3 -> satisfiable by drupal/core[9.2.3].
    - Conclusion: don't install drupal/core 9.2.3
    - drupal/core-recommended 9.2.2 requires drupal/core 9.2.2 -> satisfiable by drupal/core[9.2.2].
    - Conclusion: don't install drupal/core 9.2.2
    - drupal/core-recommended 9.2.1 requires drupal/core 9.2.1 -> satisfiable by drupal/core[9.2.1].
    - Conclusion: don't install drupal/core 9.2.1
    - drupal/core-recommended 9.2.0 requires drupal/core 9.2.0 -> satisfiable by drupal/core[9.2.0].
    - Conclusion: don't install drupal/core 9.2.0
    - drupal/core-recommended 9.2.0-rc1 requires drupal/core 9.2.0-rc1 -> satisfiable by drupal/core[9.2.0-rc1].
    - Conclusion: don't install drupal/core 9.2.0-rc1
    - drupal/core-recommended 9.2.0-beta3 requires drupal/core 9.2.0-beta3 -> satisfiable by drupal/core[9.2.0-beta3].
    - Conclusion: don't install drupal/core 9.2.0-beta3
    - drupal/core-recommended 9.2.0-beta2 requires drupal/core 9.2.0-beta2 -> satisfiable by drupal/core[9.2.0-beta2].
    - Conclusion: don't install drupal/core 9.2.0-beta2
    - drupal/core-recommended 9.2.0-beta1 requires drupal/core 9.2.0-beta1 -> satisfiable by drupal/core[9.2.0-beta1].
    - Conclusion: don't install drupal/core 9.2.0-beta1
    - drupal/core-recommended 9.2.0-alpha1 requires drupal/core 9.2.0-alpha1 -> satisfiable by drupal/core[9.2.0-alpha1].
    - Conclusion: don't install drupal/core 9.2.0-alpha1
    - Installation request for drupal/admin_menu 3.x-dev -> satisfiable by drupal/admin_menu[3.x-dev].
    - drupal/core-recommended 9.3.x-dev requires drupal/core 9.3.x-dev -> satisfiable by drupal/core[9.3.x-dev].
    - Conclusion: don't install drupal/core 9.3.x-dev
    - drupal/admin_menu 3.x-dev requires drupal/core ~8.0 -> satisfiable by drupal/core[8.9.17, 8.0.0, 8.0.0-beta10, 8.0.0-beta11, 8.0.0-beta12, 8.0.0-beta13, 8.0.0-beta14, 8.0.0-beta15, 8.0.0-beta16, 8.0.0-beta6, 8.0.0-beta7, 8.0.0-beta8, 8.0.0-beta9, 8.0.0-rc1, 8.0.0-rc2, 8.0.0-rc3, 8.0.0-rc4, 8.0.1, 8.0.2, 8.0.3, 8.0.4, 8.0.5, 8.0.6, 8.0.x-dev, 8.1.0, 8.1.0-beta1, 8.1.0-beta2, 8.1.0-rc1, 8.1.1, 8.1.10, 8.1.2, 8.1.3, 8.1.4, 8.1.5, 8.1.6, 8.1.7, 8.1.8, 8.1.9, 8.1.x-dev, 8.2.0, 8.2.0-beta1, 8.2.0-beta2, 8.2.0-beta3, 8.2.0-rc1, 8.2.0-rc2, 8.2.1, 8.2.2, 8.2.3, 8.2.4, 8.2.5, 8.2.6, 8.2.7, 8.2.8, 8.2.x-dev, 8.3.0, 8.3.0-alpha1, 8.3.0-beta1, 8.3.0-rc1, 8.3.0-rc2, 8.3.1, 8.3.2, 8.3.3, 8.3.4, 8.3.5, 8.3.6, 8.3.7, 8.3.8, 8.3.9, 8.3.x-dev, 8.4.0, 8.4.0-alpha1, 8.4.0-beta1, 8.4.0-rc1, 8.4.0-rc2, 8.4.1, 8.4.2, 8.4.3, 8.4.4, 8.4.5, 8.4.6, 8.4.7, 8.4.8, 8.4.x-dev, 8.5.0, 8.5.0-alpha1, 8.5.0-beta1, 8.5.0-rc1, 8.5.1, 8.5.10, 8.5.11, 8.5.12, 8.5.13, 8.5.14, 8.5.15, 8.5.2, 8.5.3, 8.5.4, 8.5.5, 8.5.6, 8.5.7, 8.5.8, 8.5.9, 8.5.x-dev, 8.6.0, 8.6.0-alpha1, 8.6.0-beta1, 8.6.0-beta2, 8.6.0-rc1, 8.6.1, 8.6.10, 8.6.11, 8.6.12, 8.6.13, 8.6.14, 8.6.15, 8.6.16, 8.6.17, 8.6.18, 8.6.2, 8.6.3, 8.6.4, 8.6.5, 8.6.6, 8.6.7, 8.6.8, 8.6.9, 8.7.0, 8.7.0-alpha1, 8.7.0-alpha2, 8.7.0-beta1, 8.7.0-beta2, 8.7.0-rc1, 8.7.1, 8.7.10, 8.7.11, 8.7.12, 8.7.13, 8.7.14, 8.7.2, 8.7.3, 8.7.4, 8.7.5, 8.7.6, 8.7.7, 8.7.8, 8.7.9, 8.7.x-dev, 8.8.0, 8.8.0-alpha1, 8.8.0-beta1, 8.8.0-rc1, 8.8.1, 8.8.10, 8.8.11, 8.8.12, 8.8.2, 8.8.3, 8.8.4, 8.8.5, 8.8.6, 8.8.7, 8.8.8, 8.8.9, 8.8.x-dev, 8.9.0, 8.9.0-beta1, 8.9.0-beta2, 8.9.0-beta3, 8.9.0-rc1, 8.9.1, 8.9.10, 8.9.11, 8.9.12, 8.9.13, 8.9.14, 8.9.15, 8.9.16, 8.9.18, 8.9.19, 8.9.2, 8.9.3, 8.9.4, 8.9.5, 8.9.6, 8.9.7, 8.9.8, 8.9.9, 8.9.x-dev].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.0].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.0-beta1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.0-beta2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.0-beta3].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.0-rc1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.10].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.11].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.12].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.13].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.14].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.15].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.16].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.17].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.18].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.19].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.3].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.4].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.5].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.6].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.7].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.8].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.9].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.x-dev].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.0].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.0-beta10].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.0-beta11].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.0-beta12].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.0-beta13].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.0-beta14].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.0-beta15].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.0-beta16].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.0-beta7].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.0-beta8].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.0-beta9].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.0-rc1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.0-rc2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.0-rc3].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.0-rc4].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.3].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.4].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.5].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.6].
    - Can only install one of: drupal/core[9.2.x-dev, 8.0.x-dev].
    - Can only install one of: drupal/core[9.2.x-dev, 8.1.0].
    - Can only install one of: drupal/core[9.2.x-dev, 8.1.0-beta1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.1.0-beta2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.1.0-rc1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.1.1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.1.10].
    - Can only install one of: drupal/core[9.2.x-dev, 8.1.2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.1.3].
    - Can only install one of: drupal/core[9.2.x-dev, 8.1.4].
    - Can only install one of: drupal/core[9.2.x-dev, 8.1.5].
    - Can only install one of: drupal/core[9.2.x-dev, 8.1.6].
    - Can only install one of: drupal/core[9.2.x-dev, 8.1.7].
    - Can only install one of: drupal/core[9.2.x-dev, 8.1.8].
    - Can only install one of: drupal/core[9.2.x-dev, 8.1.9].
    - Can only install one of: drupal/core[9.2.x-dev, 8.1.x-dev].
    - Can only install one of: drupal/core[9.2.x-dev, 8.2.0].
    - Can only install one of: drupal/core[9.2.x-dev, 8.2.0-beta1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.2.0-beta2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.2.0-beta3].
    - Can only install one of: drupal/core[9.2.x-dev, 8.2.0-rc1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.2.0-rc2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.2.1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.2.2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.2.3].
    - Can only install one of: drupal/core[9.2.x-dev, 8.2.4].
    - Can only install one of: drupal/core[9.2.x-dev, 8.2.5].
    - Can only install one of: drupal/core[9.2.x-dev, 8.2.6].
    - Can only install one of: drupal/core[9.2.x-dev, 8.2.7].
    - Can only install one of: drupal/core[9.2.x-dev, 8.2.8].
    - Can only install one of: drupal/core[9.2.x-dev, 8.2.x-dev].
    - Can only install one of: drupal/core[9.2.x-dev, 8.3.0].
    - Can only install one of: drupal/core[9.2.x-dev, 8.3.0-alpha1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.3.0-beta1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.3.0-rc1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.3.0-rc2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.3.1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.3.2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.3.3].
    - Can only install one of: drupal/core[9.2.x-dev, 8.3.4].
    - Can only install one of: drupal/core[9.2.x-dev, 8.3.5].
    - Can only install one of: drupal/core[9.2.x-dev, 8.3.6].
    - Can only install one of: drupal/core[9.2.x-dev, 8.3.7].
    - Can only install one of: drupal/core[9.2.x-dev, 8.3.8].
    - Can only install one of: drupal/core[9.2.x-dev, 8.3.9].
    - Can only install one of: drupal/core[9.2.x-dev, 8.3.x-dev].
    - Can only install one of: drupal/core[9.2.x-dev, 8.4.0].
    - Can only install one of: drupal/core[9.2.x-dev, 8.4.0-alpha1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.4.0-beta1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.4.0-rc1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.4.0-rc2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.4.1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.4.2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.4.3].
    - Can only install one of: drupal/core[9.2.x-dev, 8.4.4].
    - Can only install one of: drupal/core[9.2.x-dev, 8.4.5].
    - Can only install one of: drupal/core[9.2.x-dev, 8.4.6].
    - Can only install one of: drupal/core[9.2.x-dev, 8.4.7].
    - Can only install one of: drupal/core[9.2.x-dev, 8.4.8].
    - Can only install one of: drupal/core[9.2.x-dev, 8.4.x-dev].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.0].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.0-alpha1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.0-beta1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.0-rc1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.10].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.11].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.12].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.13].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.14].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.15].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.3].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.4].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.5].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.6].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.7].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.8].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.9].
    - Can only install one of: drupal/core[9.2.x-dev, 8.5.x-dev].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.0].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.0-alpha1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.0-beta1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.0-beta2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.0-rc1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.10].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.11].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.12].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.13].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.14].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.15].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.16].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.17].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.18].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.3].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.4].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.5].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.6].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.7].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.8].
    - Can only install one of: drupal/core[9.2.x-dev, 8.6.9].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.0].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.0-alpha1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.0-alpha2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.0-beta1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.0-beta2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.0-rc1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.10].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.11].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.12].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.13].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.14].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.3].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.4].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.5].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.6].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.7].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.8].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.9].
    - Can only install one of: drupal/core[9.2.x-dev, 8.7.x-dev].
    - Can only install one of: drupal/core[9.2.x-dev, 8.8.0].
    - Can only install one of: drupal/core[9.2.x-dev, 8.8.0-alpha1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.8.0-beta1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.8.0-rc1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.8.1].
    - Can only install one of: drupal/core[9.2.x-dev, 8.8.10].
    - Can only install one of: drupal/core[9.2.x-dev, 8.8.11].
    - Can only install one of: drupal/core[9.2.x-dev, 8.8.12].
    - Can only install one of: drupal/core[9.2.x-dev, 8.8.2].
    - Can only install one of: drupal/core[9.2.x-dev, 8.8.3].
    - Can only install one of: drupal/core[9.2.x-dev, 8.8.4].
    - Can only install one of: drupal/core[9.2.x-dev, 8.8.5].
    - Can only install one of: drupal/core[9.2.x-dev, 8.8.6].
    - Can only install one of: drupal/core[9.2.x-dev, 8.8.7].
    - Can only install one of: drupal/core[9.2.x-dev, 8.8.8].
    - Can only install one of: drupal/core[9.2.x-dev, 8.8.9].
    - Can only install one of: drupal/core[9.2.x-dev, 8.8.x-dev].
    - Can only install one of: drupal/core[9.2.x-dev, 8.9.17].
    - drupal/core-recommended 9.2.x-dev requires drupal/core 9.2.x-dev -> satisfiable by drupal/core[9.2.x-dev].
    - Installation request for drupal/core-recommended ^9.2.0 -> satisfiable by drupal/core-recommended[9.2.0, 9.2.0-alpha1, 9.2.0-beta1, 9.2.0-beta2, 9.2.0-beta3, 9.2.0-rc1, 9.2.1, 9.2.2, 9.2.3, 9.2.4, 9.2.5, 9.2.6, 9.2.x-dev, 9.3.x-dev].

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
 - It's a private package and you forgot to add a custom repository to find it

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

and my composer.json

{
  "name": "acquia/drupal-minimal-project",
  "description": "Minimal Acquia-compatible Drupal application based on the Drupal Recommended Project",
  "license": "GPL-2.0-or-later",
  "authors": [
    {
      "name": "Acquia Engineering",
      "homepage": "https://www.acquia.com",
      "role": "Maintainer"
    }
  ],
  "repositories": {
    "drupal": {
      "type": "composer",
      "url": "https://packages.drupal.org/8"
    }
  },
  "require": {
    "composer/installers": "^1.9",
    "cweagans/composer-patches": "^1.6",
    "dompdf/dompdf": "^1.0",
    "drupal/acquia_connector": "^3.0",
    "drupal/admin_menu": "3.x-dev",
    "drupal/admin_toolbar": "^3.0",
    "drupal/autologout": "^1.3",
    "drupal/better_exposed_filters": "^5.0@beta",
    "drupal/block_exclude_pages": "^2.0",
    "drupal/bootstrap4": "^2.1",
    "drupal/config_devel": "^1.8",
    "drupal/config_distro": "^1.0@alpha",
    "drupal/config_distro_filter": "^1.0@alpha",
    "drupal/config_filter": "2.2.0",
    "drupal/config_ignore": "^2.3",
    "drupal/config_merge": "^1.0@RC",
    "drupal/config_normalizer": "^1.0@alpha",
    "drupal/config_provider": "^2.0@RC",
    "drupal/config_snapshot": "^1.0@RC",
    "drupal/config_split": "^2.0",
    "drupal/config_sync": "^2.0@beta",
    "drupal/config_update": "^1.7",
    "drupal/console": "^1.9",
    "drupal/content_sync": "^2.1",
    "drupal/core-composer-scaffold": "^9.2.0",
    "drupal/core-project-message": "^9.2.0",
    "drupal/core-recommended": "^9.2.0",
    "drupal/custom_add_another": "^1.0@beta",
    "drupal/devel": "^4.1",
    "drupal/externalauth": "^1.4",
    "drupal/fast_404": "^2.0@alpha",
    "drupal/field_group": "^3.1",
    "drupal/fontawesome": "^2.19",
    "drupal/httpswww": "^2.0",
    "drupal/jquery_ui_accordion": "^1.1",
    "drupal/memcache": "^2.3",
    "drupal/multiple_fields_remove_button": "^1.0@alpha",
    "drupal/paragraphs": "^1.12",
    "drupal/password_policy": "^3.0",
    "drupal/select_or_other": "^1.0@alpha",
    "drupal/shield": "^1.4",
    "drupal/simplesamlphp_auth": "^3.2",
    "drupal/siteimprove": "^1.11",
    "drupal/theme_switcher": "^1.2",
    "drupal/toolbar_anti_flicker": "^9.3",
    "drupal/toolbar_menu": "^2.2",
    "drupal/twig_tweak": "^2",
    "drupal/views_bulk_operations": "^4.0",
    "drupal/views_conditional": "^1.4",
    "drupal/views_data_export": "^1.0",
    "drush/drush": "^10.5",
    "picqer/php-barcode-generator": "^2.2",
    "scriptotek/google-books": "^0.2.5",
    "tecnickcom/tcpdf": "^6.4",
    "zaporylie/composer-drupal-optimizations": "^1.2"
  },
  "minimum-stability": "dev",
  "prefer-stable": true,
  "config": {
    "sort-packages": true
  },
  "extra": {
    "drupal-scaffold": {
      "locations": {
        "web-root": "docroot/"
      },
      "file-mapping": {
        "[web-root]/sites/default/default.services.yml": {
          "mode": "replace",
          "path": "docroot/core/assets/scaffold/files/default.services.yml",
          "overwrite": false
        },
        "[web-root]/sites/default/default.settings.php": {
          "mode": "replace",
          "path": "docroot/core/assets/scaffold/files/default.settings.php",
          "overwrite": false
        }
      },
      "gitignore": true
    },
    "installer-paths": {
      "docroot/core": [
        "type:drupal-core"
      ],
      "docroot/libraries/{$name}": [
        "type:drupal-library"
      ],
      "docroot/modules/contrib/{$name}": [
        "type:drupal-module"
      ],
      "docroot/profiles/contrib/{$name}": [
        "type:drupal-profile"
      ],
      "docroot/themes/contrib/{$name}": [
        "type:drupal-theme"
      ],
      "drush/Commands/contrib/{$name}": [
        "type:drupal-drush"
      ],
      "docroot/modules/custom/{$name}": [
        "type:drupal-custom-module"
      ],
      "docroot/themes/custom/{$name}": [
        "type:drupal-custom-theme"
      ]
    },
    "enable-patching": true,
    "patchLevel": {
      "drupal/core": "-p2"
    },
    "patches": {}
  },
  "require-dev": {
    "drupal/core-dev": "^9.2.0"
  }
}

Is there anybody that can assist me with this?

Please and thank you.

4
  • The odd detail that jumps out at me is the line that says drupal/core 8.0.0-beta6 requires doctrine/common dev-master#a45d110f71c323e29f41eb0696fa230e3fa1b1b5 -> no matching package found. I'm not sure what package thinks it requires core version 8.0.0-beta6. You may want to look for that in your composer.lock. But first, see my answer below -- you may fix your Composer issues during the process of upgrading from Composer 1 to Composer 2. Sep 16, 2021 at 20:13
  • Any luck with the upgrade? Sep 20, 2021 at 14:11
  • 1
    I mostly got it. I ended up re-pulling down the acquia/minimal-project and rebuilt everything and included my custom and contrib modules in the composer. Everything seems to be good now.
    – Ex0r
    Sep 20, 2021 at 17:55
  • Acquia is great, but I recommend sticking as closely as possible to the drupal/recommended-project to avoid Composer headaches. (To be fair, now that the Acquia Lightning installation profile is nearing its end of life, the worst may be behind us!) Sep 21, 2021 at 2:18

1 Answer 1

1

You may have heard that upgrading from Drupal 8 to Drupal 9 is the easiest Drupal core upgrade yet (and that is true!) but there are still a few steps to upgrading.

Hopefully, you are using git or another form of version control, because you should start by rolling back your site to the last stable state, when you were running Drupal 8. Then you can address some prerequisites, and run some tests, before upgrading to Drupal 9.

You are still using Composer 1. You should start the upgrade by preparing your site for Composer 2. (There's a lot of info at the linked page. Usually, link-only answers are frowned upon, but it's beyond the scope of this answer to include all that info here. Besides, it's part of the official Drupal documentation on Drupal.org, so I think that's fair game for linking, unlike a blog post that might disappear.)

Once you have that straightened out, make certain that you have upgraded Drupal core and contributed modules to the very latest versions available, and then install the Upgrade Status module to test your site for Drupal 9 readiness. If it detects any problems, you'll need to fix them before upgrading.

Here's a link to the official Drupal docs on Upgrading a Drupal 8 site to Drupal 9:

Short summary

  1. Ensure your hosting environment matches the platform requirements of Drupal 9.
  2. Update to Drupal 8.8.x or 8.9.x (if not already on that version)
  3. Update all contributed projects and ensure they are Drupal 9 compatible
  4. Make custom code Drupal 9 compatible
  5. Update core codebase to Drupal 9
  6. Run update.php

If you're looking for step by step directions, you'll find more details in the upgrading section.

After you have followed all these steps, come back and update your question if you are still seeing a Composer-related error.

LATER:

OK, I'll take your word for it that you have followed all the prerequisites above.

My hunch is that you are having trouble upgrading because you are using the acquia/drupal-minimal-project, but I can't be sure.

Please create a new Drupal 8.9 project:

composer create-project drupal/recommended-project:^8.9 $SITE_NAME

Substitute your desired project name for $SITE_NAME.

Then use composer require to add all the packages from your composer.json (there are not too many, so it should not take too long.) If you have any custom modules and themes in your site, move them into the new 8.9 site at this time.

Since your site is hosted on Acquia, the one change you should make from the recommended-project is to change the docroot directory from web to docroot:

        "drupal-scaffold": {
            "locations": {
                "web-root": "docroot/"
            }
        },
        "installer-paths": {
            "docroot/core": [
                "type:drupal-core"
            ],
            "docroot/libraries/{$name}": [
                "type:drupal-library"
            ],
            "docroot/modules/contrib/{$name}": [
                "type:drupal-module"
            ],
            "docroot/profiles/contrib/{$name}": [
                "type:drupal-profile"
            ],
            "docroot/themes/contrib/{$name}": [
                "type:drupal-theme"
            ],
            "drush/Commands/contrib/{$name}": [
                "type:drupal-drush"
            ],
            "docroot/modules/custom/{$name}": [
                "type:drupal-custom-module"
            ],
            "docroot/themes/custom/{$name}": [
                "type:drupal-custom-theme"
            ]
        },

Then import the database from your site into the new 8.9 site and make sure that it runs as expected. (If you are using something like Lando, DDEV, or Docksal, this should be pretty easy. Actually I recommend setting up Lando with the new Acquia recipe, which is pretty sweet.)

After that, you should be able to complete the Drupal 9 upgrade by following the instructions I linked to above:

https://www.drupal.org/docs/upgrading-drupal/upgrading-from-drupal-8-to-drupal-9-or-later#s-upgrading-a-composer-based-drupal-8-site

Note: this is not as simple as manually updating a composer.json file and running composer update. In particular:

Temporarily add write access to protected files and directories:

chmod 777 web/sites/default
chmod 666 web/sites/default/*settings.php
chmod 666 web/sites/default/*services.yml

Next, you'll need to pull in both the Drupal 9 version of core-recommended and dev-dependencies packages as dependencies. We use --no-update to avoid a chicken-and-egg problem with mutual dependencies:

composer require 'drupal/core-recommended:^9' 'drupal/core-composer-scaffold:^9' 'drupal/core-project-message:^9' --update-with-dependencies --no-update

If you have drupal/core-dev installed:

composer require 'drupal/core-dev:^9' --dev --update-with-dependencies --no-update

Now, actually perform the update to the code itself:

composer update

That's all the advice I have! Good luck!

1
  • 1
    Thanks for your response. I should have included in my original post that I have done all the pre-requisite stuff to upgrade to 9 and no issues were found. I also do not have a composer.lock as I removed it to see if it would update, to which it didn't. I did update to composer 2, however I'm still getting the same errors, albeit faster than using composer 1.
    – Ex0r
    Sep 17, 2021 at 0:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.