1

My upgrade is failing. I am at 8.9.19 and I used upgrade-status to make sure all my modules are compatible with next major core version. I am following instructions at https://www.drupal.org/docs/upgrading-drupal/upgrading-from-drupal-8-to-drupal-9-or-later

When I get to step 3, running composer update, I get these problems:

- Root composer.json requires drupal/devel ^2.1 -> satisfiable by drupal/devel[2.1.0, 2.x-dev (alias of dev-2.x)].
- drupal/core-recommended 9.1.0-alpha1 requires symfony/var-dumper v5.1.7 -> satisfiable by symfony/var-dumper[v5.1.7].
- Conclusion: don't install symfony/var-dumper v5.1.7 (conflict analysis result)
- drupal/core-recommended 9.2.0-alpha1 requires symfony/var-dumper v5.2.6 -> satisfiable by symfony/var-dumper[v5.2.6].
- Conclusion: don't install symfony/var-dumper v5.2.6 (conflict analysis result)
- drupal/core-recommended 9.3.0-alpha1 requires symfony/var-dumper v5.3.8 -> satisfiable by symfony/var-dumper[v5.3.8].
- Conclusion: don't install symfony/var-dumper v5.3.8 (conflict analysis result)
- drupal/core-recommended[9.2.0-beta1, ..., 9.2.0-beta2] require symfony/var-dumper v5.2.8 -> satisfiable by symfony/var-dumper[v5.2.8].
- Conclusion: don't install symfony/var-dumper v5.2.8 (conflict analysis result)
- drupal/core-recommended 9.2.0-beta3 requires symfony/var-dumper v5.3.0-RC1 -> satisfiable by symfony/var-dumper[v5.3.0-RC1].
- Conclusion: don't install symfony/var-dumper v5.3.0-RC1 (conflict analysis result)
- drupal/core-recommended[9.0.0-beta3, ..., 9.0.0-rc1] require symfony/var-dumper v5.0.8 -> satisfiable by symfony/var-dumper[v5.0.8].
- Conclusion: don't install symfony/var-dumper v5.0.8 (conflict analysis result)
- drupal/core-recommended[9.0.0, ..., 9.0.12] require symfony/var-dumper v5.1.0 -> satisfiable by symfony/var-dumper[v5.1.0].
- Conclusion: don't install symfony/var-dumper v5.1.0 (conflict analysis result)
- drupal/core-recommended[9.1.0-beta1, ..., 9.1.7] require symfony/var-dumper v5.1.8 -> satisfiable by symfony/var-dumper[v5.1.8].
- Conclusion: don't install symfony/var-dumper v5.1.8 (conflict analysis result)
- drupal/core-recommended[9.0.13, ..., 9.1.x-dev] require symfony/var-dumper v5.1.11 -> satisfiable by symfony/var-dumper[v5.1.11].
- Conclusion: don't install symfony/var-dumper v5.1.11 (conflict analysis result)
- drupal/core-recommended[9.2.0-rc1, ..., 9.2.x-dev] require symfony/var-dumper v5.3.0 -> satisfiable by symfony/var-dumper[v5.3.0].
- Conclusion: don't install symfony/var-dumper v5.3.0 (conflict analysis result)
- drupal/core-recommended 9.0.0-alpha1 requires composer/installers v1.7.0 -> satisfiable by composer/installers[v1.7.0].
- drupal/core-recommended[9.0.0-alpha2, ..., 9.0.0-beta2] require composer/installers v1.8.0 -> satisfiable by composer/installers[v1.8.0].
- composer/installers[v1.7.0, ..., v1.8.0] require composer-plugin-api ^1.0 -> found composer-plugin-api[2.1.0] but it does not match the constraint.
- drupal/core-recommended[9.3.x-dev, ..., 9.4.x-dev] require symfony/var-dumper v5.3.10 -> satisfiable by symfony/var-dumper[v5.3.10].
- Conclusion: don't install symfony/var-dumper v5.3.10 (conflict analysis result)
- Root composer.json requires drupal/core-recommended ^9 -> satisfiable by drupal/core-recommended[9.0.0-alpha1, ..., 9.4.x-dev].

I don't understand the issues or what to do. var-dumper is not in my composer.json, but I do see it in k

I have also tried running update with -W, no change. How do I tell what version is being used? Do I need to install or delete something? Running symfony/var-dumper shows this:

drupal/devel           2.1.0    requires   symfony/var-dumper (~2.7|^3|^4)           
psy/psysh              v0.10.9  requires   symfony/var-dumper (~5.0|~4.0|~3.0|~2.7)  
symfony/error-handler  v4.4.30  requires   symfony/var-dumper (^4.4|^5.0)            
symfony/http-kernel    v3.4.49  conflicts  symfony/var-dumper (<3.3)                 

Here is my complete composer.json:

{
    "name": "drupal-composer/drupal-project",
    "description": "Project template for Drupal 8 projects with composer",
    "type": "project",
    "license": "GPL-2.0-or-later",
    "authors": [
        {
            "name": "",
            "role": ""
        }
    ],
    "dependencies": {
    },
    "repositories": {
        "drupal": {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        }
    },
    "require": {
        "php": ">=7.0.8",
        "composer/installers": "^1.2",
        "cweagans/composer-patches": "^1.6",
        "drupal/addanother": "^1.0",
        "drupal/admin_toolbar": "^2.3",
        "drupal/adminimal_admin_toolbar": "^1.11",
        "drupal/adminimal_theme": "^1.5",
        "drupal/advagg": "^4.1",
        "drupal/backup_migrate": "^5.0@RC",
        "drupal/bamboo_twig": "^5.0-alpha1",
        "drupal/better_exposed_filters": "^5.0",
        "drupal/block_field": "^1.0@RC",
        "drupal/blog": "^3.0",
        "drupal/classy_paragraphs": "^1.0@beta",
        "drupal/coffee": "^1.0",
        "drupal/config_delete": "^1.17",
        "drupal/config_inspector": "^1.1",
        "drupal/config_update": "^1.7",
        "drupal/console": "~1.0",
        "drupal/contentimport": "^9.3",
        "drupal/context": "^4.0@beta",
        "drupal/core-composer-scaffold": "^9",
        "drupal/core-project-message": "^9",
        "drupal/core-recommended": "^9",
        "drupal/createandcontinue": "^1.2",
        "drupal/cshs": "^2.3",
        "drupal/ctools": "^3.4",
        "drupal/d8w3css": "^1.17",
        "drupal/devel": "^2.1",
        "drupal/disable_messages": "^2.0",
        "drupal/draggable_dashboard": "^1.4",
        "drupal/ds": "^3.7",
        "drupal/editablefields": "^1.0@beta",
        "drupal/email_registration": "^1.1",
        "drupal/empty_page": "^3.0",
        "drupal/entity": "^1.1",
        "drupal/entity_browser": "^2.5",
        "drupal/entity_print": "^2.2",
        "drupal/entity_reference_revisions": "^1.8",
        "drupal/entity_usage": "^2.0@beta",
        "drupal/examples": "^3.0",
        "drupal/extlink": "^1.5",
        "drupal/field_group": "^3.1",
        "drupal/graphql": "^3.0",
        "drupal/graphql_core": "^3.0",
        "drupal/homebox": "1.x-dev",
        "drupal/htmlmail": "^3.0@alpha",
        "drupal/image_effects": "^3.0",
        "drupal/inline_entity_form": "^1.0@RC",
        "drupal/jquery_ui": "^1.4",
        "drupal/jquery_ui_accordion": "^1.1",
        "drupal/jquery_ui_datepicker": "^1.1",
        "drupal/libraries": "^3.0@alpha",
        "drupal/link_attributes": "^1.11",
        "drupal/mailcontrol": "^1.2",
        "drupal/maillog": "^1.0@beta",
        "drupal/mailsystem": "^4.3",
        "drupal/menu_per_role": "^1.3",
        "drupal/metatag_head_title": "^1.1",
        "drupal/module_filter": "^3.1",
        "drupal/multiple_registration": "^2.92",
        "drupal/openapi": "^2.0@RC",
        "drupal/openapi_ui": "^1.0@RC",
        "drupal/paragraphs": "^1.12",
        "drupal/pathauto": "^1.8",
        "drupal/profile": "^1.1",
        "drupal/publication_date": "^2.0@beta",
        "drupal/publishcontent": "^1.3",
        "drupal/redirect": "^1.6",
        "drupal/registration_types": "^1.0@beta",
        "drupal/rename_admin_paths": "^2.0",
        "drupal/responsive_menu": "4.4.1",
        "drupal/save_edit": "^1.3",
        "drupal/sendgrid_integration": "^1.7",
        "drupal/simple_sitemap": "^3.10",
        "drupal/simplelogin": "^6.0",
        "drupal/system_stream_wrapper": "^1.0@alpha",
        "drupal/tablesorter": "^2.0@beta",
        "drupal/taxonomy_manager": "^2.0",
        "drupal/term_csv_export_import": "^3.0@alpha",
        "drupal/token": "^1.7",
        "drupal/twig_debugger": "^1.1",
        "drupal/twig_field_value": "^2.0",
        "drupal/twig_tweak": "^2.6",
        "drupal/twigsuggest": "^1.0@beta",
        "drupal/typed_data": "^1.0@alpha",
        "drupal/upgrade_status": "^3.11",
        "drupal/vertical_tabs_config": "^1.3",
        "drupal/viewfield": "^3.0@beta",
        "drupal/views_autocomplete_filters": "^1.3",
        "drupal/views_bulk_edit": "^2.4",
        "drupal/views_bulk_operations": "^3.9",
        "drupal/views_conditional": "^1.3",
        "drupal/views_natural_sort": "^2.0@alpha",
        "drupal/views_taxonomy_term_name_into_id": "^1.0@alpha",
        "drupal/watchdog_prune": "^2.1",
        "psr/log": "^1.1",
        "twig/extensions": "^1.5",
        "vlucas/phpdotenv": "^4.0",
        "webflo/drupal-finder": "^1.0.0",
        "zaporylie/composer-drupal-optimizations": "^1.0"
    },
    "require-dev": {
        "drupal/core-dev": "^9"
    },
    "conflict": {
        "drupal/drupal": "*"
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "config": {
        "sort-packages": true
    },
    "autoload": {
        "classmap": [
            "scripts/composer/ScriptHandler.php"
        ],
        "files": ["load.environment.php"]
    },
    "scripts": {
        "pre-install-cmd": [
            "DrupalProject\\composer\\ScriptHandler::checkComposerVersion"
        ],
        "pre-update-cmd": [
            "DrupalProject\\composer\\ScriptHandler::checkComposerVersion"
        ],
        "post-install-cmd": [
            "DrupalProject\\composer\\ScriptHandler::createRequiredFiles"
        ],
        "post-update-cmd": [
            "DrupalProject\\composer\\ScriptHandler::createRequiredFiles"
        ]
    },
    "extra": {
        "composer-exit-on-patch-failure": true,
        "patchLevel": {
            "drupal/core": "-p2"
        },
        "drupal-scaffold": {
            "locations": {
                "web-root": "web/"
            }
        },
        "installer-paths": {
            "web/core": ["type:drupal-core"],
            "web/libraries/{$name}": ["type:drupal-library"],
            "web/modules/contrib/{$name}": ["type:drupal-module"],
            "web/profiles/contrib/{$name}": ["type:drupal-profile"],
            "web/themes/contrib/{$name}": ["type:drupal-theme"],
            "drush/Commands/contrib/{$name}": ["type:drupal-drush"]
        }
    }
}

1 Answer 1

3

It's the devel module that prevents you from installing. As this line indicates, it requires a version of symfony/var-dumper that is not compatible with Drupal 9:

drupal/devel           2.1.0    requires   symfony/var-dumper (~2.7|^3|^4) 

If you change devel to the current version, e.g. ^4.1 then it should install.

2
  • 1
    Working fine, thanks for the suggestion. I've been using Drupal for over a decade, but composer has been a bit of a mystery. Now I know a little more about where to look.
    – pglatz
    Nov 7, 2021 at 19:17
  • Yes, composer, and especially it's errors, can be challenging and frustrating. I know that too ;)
    – berliner
    Nov 7, 2021 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.