0

I am using the webforms module (6.1.1) on a Drupal 8 site for a form that shows up in a block on my front page.

If I am not logged in (go Incognito or InPrivate mode) the form displays and works.

If I am logged in, the form does not show, but the < div> it is located in does.

It works in the admin pages as expected.

I have verified that the Webform's Access has Roles "Anonymous user", "Authenticated user" and "Administrator" checked.

I have verified the Block also has Roles "Anonymous user", "Authenticated user" and "Administrator" checked.

Looking in the browser's developer view at the space where the form should be, I get the following code instead. I don't know if it is relevant or not.

<span data-big-pipe-placeholder-id="callback=Drupal%5Cblock%5CBlockViewBuilder%3A%3AlazyBuilder&amp;args%5B0%5D=webform&amp;args%5B1%5D=full&amp;args%5B2%5D&amp;token=DAFi9sg2c3cBjy5LxuoGFFwM6MALQtu8KIca_a1b5E8"></span>

This is opposite than most web hits that talk about the form not showing up for anonymous users.

Thank you.

1 Answer 1

1

This is not a webform issue. The problem is that BigPipe is unable to lazily load the block. What happens if you disable this module?

If you want to debug the module, server-side it is delivering the content for placeholders delayed at the end of the page (scroll down in the HTML source). Client-side this is then processed in javascript. Check if javascript is running without errors.

You can also try to change the theme, that's the most likely cause for such errors by not rendering the HTML markup and the attached libraries correctly.

1
  • Seeing what BigPipe is (for caching) I went to the sites' Performance and changed the caching from "<no cache>" to "1 minute" and the content displays on the page for the authenticated user. Changed it back and and the form still renders for me as an authenticated user. Double checked and it does continue to work for the unauthenticated user as well. Thanks.
    – Hometoy
    Commented Dec 3, 2021 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.