0

I built a simple Drupal 8 website on my DEV box and moved it to the LIVE server.

  1. Copied the files on the DEV server into a tarball
  2. Moved these file to the LIVE server (using scp).
  3. Uncompressed web files into it's destination directory (/var/www/html/newsite)
  4. Created the database, user and set permissions to match that on the DEV server
  5. Backed up the MySQL Server database into a .sql file with mysqldump
  6. Imported from the .sql file into the database of the same name
  7. Made sure the APACHE settings pointed to the site's directory

When I navigate to the front page, it comes up.

  • Images and page content displays
  • Webform works and emails the account it is set for

BUT cannot navigate to any other page!

  • /user = Page not found
  • /[anything] = Page not found
  • /?q=user = goes to the (front) page and the URL remains with the
  • /?=[anything] = shows the front page with the URL remaining

Meaning I cannot log in or run (database) updates!

I've tried

  • deleting the Sessions table in the database
  • verify mod_rewrite is enabled in httpd (CentOS)
  • verified the apache (httpd) config files match

Any help or ideas appreciated.

I don't think wiping out the website, install a Drupal site and then copy the files/database over the new one would fix anything.

5
  • Have you got a copy of the Drupal .htaccess file in the webroot?
    – Jaypan
    Dec 6, 2021 at 21:02
  • 1
    Those are the exact symptoms of a missing/unprocessed .htaccess file
    – Clive
    Dec 6, 2021 at 21:02
  • There is a .htaccess file in the webroot. What am I looking for in the file?
    – Hometoy
    Dec 6, 2021 at 21:12
  • 2
    Do you have AllowOverride All in the vhost? If yes, is the <Directory> path that's under definitely correct?
    – Clive
    Dec 6, 2021 at 21:13
  • Try truncating all the cache tables and running the 'update.php' file or using Drush (drush updb).
    – npcoder
    Dec 6, 2021 at 22:11

1 Answer 1

1

Clive, you are correct.

Looking in the /etc/httpd/conf/httpd.conf (Apache configuration file on RedHat based distributions such as CentOS) I added the directory and include the AllowOverride All.

Once I refreshed it works! Thank you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.