0

Using Drupal 9, latest release of Commerce 8.x-2.28. I followed the Lugwig install instructions for the Commerce module. Everything seemed to install OK.

When I fill out the Create Store form, I get an error. The log shows: Location http://d9.susansmithjones.com/store/add/online Referrer http://d9.susansmithjones.com/store/add/online

Message Error: Class 'Doctrine\Common\Collections\ArrayCollection' not found in CommerceGuys\Addressing\Subdivision\Subdivision->__construct() (line 117 of /home/dsusansm/public_html/modules/address/lib/commerceguys-addressing/v1.0.9/src/Subdivision/Subdivision.php)

To review, the Commerce menu is showing and allows me to access the form to create a store. But when I try saving, I get the above message. It seems somehow related to addresses? What have I forgotten to do before creating the store? -->

4
  • 1
    Lugwig install instructions never heard of it. I suggest you install commerce using Composer instead, which is the preferred way.
    – No Sssweat
    Commented Dec 8, 2021 at 12:11
  • 1
    Yeah, Ludwig just isn't going to cut it for Commerce 2.x. Commented Dec 8, 2021 at 16:32
  • 1
    I used Ludwig because I tried to use composer and it failed. There is a whole doc page on installing Commerce with Ludwig. Perhaps I will go back and try composer again. This is very frustrating.
    – EBasye
    Commented Dec 9, 2021 at 17:13
  • Composer is the standard/the best way to go, but there certainly is a reason/demand for what Ludwig offert since there is more than 10k sites that use it.
    – Dadaisme
    Commented Dec 27, 2021 at 3:30

1 Answer 1

0

That issue is resolved with the latest dev version of Address, see https://www.drupal.org/project/address/issues/3126733

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.