0

I created a new content type and a display page to show a listing of all my new content type pages. I'm trying to create a better exposed filter block on my page for the sidebar, but when I try to add the block view to my page, I don't see it listed.

I have another content type which uses exactly the same filters and I mirrored the same settings, but it still doesn't show up. I added this filter block as a test to see if my page is rendering correctly and it does show up in the sidebar.

The filter criteria contains an exposed search bar and an exposed filter by programs. Within the advanced settings:

  • exposed form in block: yes
  • exposed form style: better exposed filters
  • admin comment: none
  • use ajax: no (I read that selecting yes worked, but it didn't work for me)

Am I missing a step or is there like a module I have to create? I included a screenshot of how the filter block should look like if it worked and which I'm trying to re-create. I also attached a screenshot of my settings for the view.

enter image description here

enter image description here

2
  • "Use Ajax" is not a requirement to have an exposed filters block work. Can you provide a screenshot of your View settings? Are you able to see your exposed filters on top of the View if you deactivate the "exposed form in block" option?
    – misterdidi
    Dec 29 '21 at 20:31
  • @misterdidi added a screenshot of my view settings. Yes, I can see my exposed filters on top of the view if I disable "exposed form in block". My initial view was using a table format, but when I change it to a column format with a pattern, it doesn't show anything. Which I would need to fit into the sidebar.
    – wolves11
    Dec 29 '21 at 21:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.