0

I am developing a site using Drupal 6. Sometimes, when I edit and save a node, the author information is lost and the node is unpublished.

Some observations:

  • When I edit the node again, even with the user 1 account, I no longer get the node publication controls on the edit form.
  • In the content overview admin page, the column for author is empty, not 'anonymous'.
  • I can force-publish the node again using bulk operations, but not via the edit node page. I cannot seem to restore the/a author for the node.

I have not yet been able to reproduce this problem consistently: it happens on various node types, only sometimes, regardless of using tinyMCE or filtered HTML for content.

It does seem to happen only on edit, not create. I have not recently enabled or disabled any modules.

Has anyone else experienced something similar? Any idea as to what might be causing this?

0

That sounds strange and like a sideeffect. I would try do debug this using the devel-module. Write a Module and print (with dsm) the $node inside hook_nodeapi. Inspect the content in subject to the operation ($op). Maybe do this two times with diffrent module weights (-1000, 2000) to see if any hook_nodeapi implementation of another module fails.

0

I seem to have found the cause of this problem in this Drupal issue. Apparently, there's a bug that causes the combination of the vertical tabs module, translations and uploaded files to mess up the node edit form — causing information to be lost.

If you follow the trail on the above link, you'll find there's no real solution yet (although there are core patches).

The best workaround I have found is disabling the vertical tabs module.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.