Utilising an Ubuntu (currently 11.04) box for WebDev in my SoHo, it's primarily for Drupal V7 projects using pure Linux LAMP and not any xamp, wamp models. I have a number of Drupal installs for dev and self-learning etc and hence Drupal version installs and modules change. I installed Drush 4.4 via the Ubuntu Synapatic manager and it installed seemingly ok, but when I try to run Drush from the Dash Home (HUD), nothing appears to load or run.

I'm the only user on the computer so I have all priviledges etc and all my Drupal projects are in var/www/ in order to emulate any future live web models. In order to be more efficient in updating Drupal and modules, I'd rather use Drush for Drupal updates as updating 6-8 projects is too labourious. Can anyone shed some light on why Drush is/or not running and what I need to do to simplify it's loading (a simple desktop link creation would be great). My current Linux experience is some 24 months having crossed over 100% from MS Windows O/S, but my DOS CLI experience was also then poor, so my knowledge was limited (but growing). Thank you.

1 Answer 1


Your problem is probably that Drush is not in your $PATH. I did not try to install Drush-4.4 from Synaptic to test whether or not this is the case; instead, I would recommend that you install Drush via PEAR following the instructions on the Drush project page. If you do this, your $PATH will be set, Drush will be found, and better yet, you'll be able to use the much-improved Drush-5.1 instead of the out-of-date Drush-4.4.

Edit: By "Dash Home", do you mean that you are trying to type "drush" into the Unity Heads-Up Display? If so, instead run "terminal" from HUD, and then type "drush status" from the terminal prompt. Then you should be good to go. I'd still recommend installing 5.1 via PEAR.

  • "Edit: By "Dash Home", do you mean that you are trying to type "drush" into the Unity Heads-Up Display?" That's correct. Terminal runs fine, "drush status" replies: PHP configuration : /etc/php5/cli/php.ini Drush version: 4.4 Drush configuration: Drush alias files: Thanks for the advice, I'll look to install via PEAR
    – Paul B
    May 13, 2012 at 14:44
  • Thanks Greg. I appeared to have fixed the error by typing: pear channel-discover pear.drush.org pear install drush/drush with SUDO added to the front. Now when I type Drush in the Terminal I get the list of Drush commands. I presume this is the correct way to use Drush? Maybe I was thinking that using the HUD would bring a "Drush" terminal.Clarification on this being correct would help. I shall refer to drush.ws for a list of commands/help.
    – Paul B
    May 13, 2012 at 14:56
  • 1
    You are correct; drush is run in the Terminal. It is a command-line tool, and does not have "Drush terminal" of its own. Sounds like it is working for you perfectly now; it might be helpful to read a bash tutorial (there are many, but one option is: linuxconfig.org/Bash_scripting_Tutorial). Do read the Drush command help, and also be sure to run the drush topic command and read the sections there that look interesting. There's a lot to learn here, but you'll find bash + drush will save you a lot of time in the long run. May 13, 2012 at 18:50
  • Drush successfully installed but I'm having 'novice' issues getting Drush 4.x to find my www/sites. I'm running Ubuntu 10.4x and all my drupal sites projects as simply in var/www/. From my 'early' internet days in '95 using the Drush terminal reminds me of the old ftp commands one use to use to transfer, (but maybe my head is still stuck in the winXP world!) still the Drush approach seems fine, but I cannot get it to find the dozen or so Drupal projects in var/www. Maybe I'm doing something simply wrong. Drush is installed in the files DIR under usr/share/drush. Can I/should I move it to www?
    – Paul B
    May 18, 2012 at 15:55
  • Drush Status shows:paulb@nexus:~$ drush status PHP configuration : /etc/php5/cli/php.ini Drush version : 4.4 Drush configuration : Drush alias files :
    – Paul B
    May 18, 2012 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.