0

I'm running a D7 with the Metatag module 7.x-1.28, no other Metatag modules are enabled.

On my front page node I: a) changed the metatag description from the old text to a new description text. b) in the metatag config at admin/config/search/metatags I have also changed for the FrontPage the description of the metatag to the same new description text.

The problem is that despite the many actions that I took, when I access the frontpage again and view the source in the metatag description the old text appears.

 <title>My site</title>         <meta name="description" content="Old text" />

Here are the actions that I took:

  1. cleared the cache from admin/config/development/performance very many times
  2. opened in chrome ingonito or edge inprivate
  3. emptied all the tables of drupal that had the word "cache" in the table name
  4. searched in the whole database in phpadmin for the old text, and I couldn't find it
  5. searched in the whole database in phpadmin for the new text and I could find it
  6. opened a ticket with the hosting company to make sure that the cache is not on their side, they confirmed it's not, and I do not have cloudflare enabled, nor cdn, nor Memcache
  7. accessed the site from a computer where I have never accessed this site before

Despite all the above the "Old text" is still there in the page source...

What could be the issue?

2
  • 2
    I can't remember if D7 has template cache, but either way...as a last check, run grep -r "Old text" sites/default/files, or equivalent, in case it's maybe in a stale template file that's still getting picked up. If not, from all the debugging steps you mentioned, I can't think of anything it could be other than a proxy caching the response somewhere between your test machines and the origin server
    – Clive
    Mar 30 at 19:44
  • The HTTP response headers would probably reveal a proxy if one exists. But if you edit some page content, and you see that change but the header remains, it’s not a network cache to blame.
    – cilefen
    Mar 30 at 20:38

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.