0

I am using a entity reference view and I am able to filter via taxonomy terms directly, but when I set it to exposed and let the user decide, it does not display on the form. How can I get the expose functionality to actually work?

It works on other things like pages and blocks, but not entity reference.

I have Views Entity Reference Filter and Better Exposed Filters already installed, but that didn't seem to fix the issue.

2
  • You said it is not shown on the form. For which users-- admins, authenticated users, anonymous users? Apr 2 at 14:25
  • Its not shown on the form for any users, no matter the role, including admins
    – Shawn
    Apr 2 at 14:26

1 Answer 1

0

Instead of a Views filter you can filter via the widget autocomplete if you add a relationship for the taxonomy field, add the taxonomy Name field to the field list and then select the Name field as search field in Format:Entity Reference list | Settings.

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.