0

I am trying to debug the functional tests for my custom module.
When I run the debugger, it doesn't hit the breakpoint I've set on the first line of the test method. However, when I debug a functional test from the Node module, it works.

5
  • Have you tried using xdebug_break() at your breakpoint? Often helps because it forces a break even if the mapping is not correct (which sounds like a possible reason for this issue) Commented Apr 15, 2022 at 17:31
  • This did not work for me. Commented Apr 18, 2022 at 13:12
  • The mappings would have to be correct for the Node module to be debugged. PHPStorm uses the parent mapping for its sub directories and files. So as long as my structure matches (it does) then it shouldn't be a mapping issue. Commented Apr 18, 2022 at 14:06
  • In that case it sounds like your code is not being executed. So that should be the focus of your efforts now, I guess. Commented Apr 19, 2022 at 13:15
  • Alright, so if I don't run the debugger and instead just run the test. The test does get executed and comes back as passed with multiple assertions. Commented Apr 19, 2022 at 20:42

1 Answer 1

0

Open PHPStorm and go to file > Invalidate Caches...

1
  • I think the question needs a few adjustments if this is the answer.
    – mona lisa
    Commented Apr 21, 2022 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.