0

I'm writing my first D7 to D9 migration by taking the migrate-upgrade configure files and bring them over one-by-one, and tweaking as needed to pull only over a small subset of my data. Things are going fairly well, and I have a few content types, fields, and content coming over as expected.

I tweaked the source plugin "d7_field" so I only pull a few fields from the old site, all of them field types offered with core. I have one D7 "text_long" field that just isn't coming over with the rest, and I can't figure out why. Migrate is adding it to migrate_map_flagship_migrate_field as follows:

source_ids_hash: 70ef5e18a834e45c197557fff5812a7b7a0ddeec0cd8198c6ea521f2f0e38083
sourceid1: field_short_description
sourceid2: node
destid1: NULL
destid2: NULL
source_row_status: 2
rollback_action: 0
last_imported: 0
hash:

Which I think is wrong, but I don't know why. All the other text fields have a destid1, destid2, and source_row_status like this:

source_ids_hash: 25b9a8f1f502fe0dc79ab1d42ff7397efaef85aed6a45d893235a0b2994ff298
sourceid1: field_includes
sourceid2: node
destid1: node
destid2: field_includes
source_row_status: 0
rollback_action: 0
last_imported: 0
hash:

Anyone have any ideas on where i can start digging into why this field is stubbornly not migrating properly?

1 Answer 1

0

FOUND! It's a known issue.

In Drupal 7, the text processing settings are defined on Field instance settings. In other words, the same field can be used on two (or more) content types and the text processing settings can be Plain text on one content type and Filtered text on another.

Drupal 8 or higher has separate field storage types Text (plain) and Text (formatted). There's also Text (plain, long) and Text (formatted, long). The important part here is that this selection is done on field storage level. In other words, the plain/formatted selection can't be changed per content type.

https://www.drupal.org/docs/upgrading-drupal/known-issues-when-upgrading-from-drupal-6-or-7-to-drupal-9-or-higher#plain-text

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.