0

enter image description hereI have managed to enter in the aegir panel and change the password. I have noticed that the platform hostmaster verify has an alert:

“ sudo: no tty present and no askpass program specified” - warning

I did some research In this forum and I tried to modify the file /etc/sudoers.tmp but it didn’t work. I have also tried many solutions proposed in this post: https://stackoverflow.com/questions/21659637/how-to-fix-sudo-no-tty-present-and-no-askpass-program-specified-error but they didn't work.

Any other idea how to fix this? Thank you for your help.

5
  • 1
    If it's not causing any problems, you can ignore it. Looks like you already found the issue at drupal.org/project/provision/issues/2842473 .
    – colan
    May 3 at 13:06
  • Thank you! yes I believe i will disable the 2 modules to "fix permission". They really don't help.
    – Gilles9999
    May 3 at 22:53
  • @colan I am not able to access to phpmyadmin that is in the folder "hostmaster-7.x-3.192". it should be accessible through "panel.example.org/phpmyadmin". At least in a previous installation it worked like that. Now I this new installation I am having the issue of "no tty present and no askpass program specified" and I guess that can be related to the access to that folder. where do you usually put the folder phpmyadmin ? (inside aegir I mean) Thanks
    – Gilles9999
    May 4 at 0:37
  • Sorry, I can't really help with that as I don't use it. I just access the DB from the CLI by running drush @site sql-connect.
    – colan
    May 5 at 13:15
  • Thank you Colan! I will try that too
    – Gilles9999
    May 5 at 14:45

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.