0

I needed to find-and-replace text across several nodes in my database, so I exported it via PHPMyAdmin and then ran the find-and-replace on the resultant .sql file. I then dropped all tables in my database and imported the edited .sql file. Now when I inspect my database with PHPMyAdmin I see that the text I removed with the find-and-replace is no longer there; however when I view or edit a node with the text I've replaced I see the replaced text still there. This is despite the fact that if I search for that text in the .sql file I imported (or a fresh .sql export after the import) I don't find it anywhere.

Why is this? How can I fix it, and successfully find-and-replace text in my site with the method above (or some better method, though that's slightly changing the question)?

Example

If you view source on http://gwwc2.centreforeffectivealtruism.org/node/546 you'll see at the start of the node content:

<style type="text/css"> <!--        @page { margin: 2cm }       P { margin-bottom: 0.21cm }         A:link { color: #2198a6; text-decoration: none }    -->     </style>

However when I run SELECT body_value FROM field_revision_body WHERE entity_id=546 (which seems to be the right query as I'm using D7) I don't see this anywhere in what's returned, which instead starts:

<p>A perennial criticism
1

Have you refreshed your caches? Configuration -> Development -> Performance -> Clear all caches

  • blush - that fixed it, for some reason I thought I had caching off. – tog22 May 15 '12 at 11:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.