1

I am following the instructions given on Updating Drupal core via Composer for users using the drupal/core-recommended package.

I have the following lines in the composer.json file.

    "minimum-stability": "dev",
    "prefer-stable": true,
   "require": {
     "drupal/core-composer-scaffold": "^9",
     "drupal/core-project-message": "^9",
     "drupal/core-recommended": "^9",
   },
   
 "require-dev": {
        "drupal/core-dev": "^9"
    },

Instead of Drupal 9.4.5, I get Drupal 9.5.0-dev.

Can anybody explain why?

0

1 Answer 1

2

I needed to change

    "require": {
         ...
        "drupal/core-composer-scaffold": "^9",
        "drupal/core-project-message": "^9",
        "drupal/core-recommended": "^9",
         ...
        },
   
 "require-dev": {
        "drupal/core-dev": "^9"
    },

to

    "require": {
         ...
        "drupal/core-composer-scaffold": "^9.4",
        "drupal/core-project-message": "^9.4",
        "drupal/core-recommended": "^9.4",
         ...
        },
   
 "require-dev": {
        "drupal/core-dev": "^9.4"
    },
1
  • 1
    Had the same recently from 9.4 to 9.5-dev and couldn't find a reason why this has happened. Thank you for posting that fix.
    – leymannx
    Sep 6, 2022 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.