0

I've got a Drupal 9.4 site that I've upgraded my database stack (XAMPP dev stack) to the latest version that is using php 8.1, but now have package incompatibilities showing up when I try to run "composer udpdate". Even trying to update with all dependencies fails. My site runs fine, however I can no longer update anything in composer without fixing whatever dependency issues there are. This is what it tells me are the problems:

Problem 1
- zendframework/zend-feed[dev-master, dev-develop, 2.11.0, ..., 2.13.x-dev] require php ^5.6 || ^7.0 -> your php version (8.1.6) does not satisfy that requirement.
- laminas/laminas-feed[2.12.0, ..., 2.12.x-dev] require php ^5.6 || ^7.0 -> your php version (8.1.6) does not satisfy that requirement.
- symfony/psr-http-message-bridge[v1.1.0, ..., 1.1.x-dev] require php ^5.3.3 || ^7.0 -> your php version (8.1.6) does not satisfy that requirement.
- symfony-cmf/routing[1.4.0-RC1, ..., 1.4.x-dev] require php ^5.3.9|^7.0 -> your php version (8.1.6) does not satisfy that requirement.
- symfony/psr-http-message-bridge[v1.2.0, ..., v1.3.0] require php ^7.1 -> your php version (8.1.6) does not satisfy that requirement.
- laminas/laminas-feed[2.13.0, ..., 2.14.x-dev] require php ^7.3 || ~8.0.0 -> your php version (8.1.6) does not satisfy that requirement.
- drupal/core[8.9.11, ..., 8.9.x-dev] require php ^7.0.8 -> your php version (8.1.6) does not satisfy that requirement.
- drupal/ckeditor_config[3.0.0-beta1, ..., 3.x-dev] require drupal/ckeditor ^8.5 -> satisfiable by drupal/core[8.5.0-alpha1, ..., 8.9.x-dev].
- drupal/core[8.5.0-alpha1, ..., 8.7.7] require symfony-cmf/routing ^1.4 -> satisfiable by symfony-cmf/routing[1.4.0-RC1, ..., 1.4.x-dev].
- drupal/core[8.7.8, ..., 8.9.10] require symfony/psr-http-message-bridge ^1.1.2 -> satisfiable by symfony/psr-http-message-bridge[v1.1.2, 1.1.x-dev, v1.2.0, v1.3.0].
- drupal/core[8.8.0-alpha1, ..., 8.8.x-dev] require zendframework/zend-feed ^2.12 -> satisfiable by laminas/laminas-feed[2.12.0, ..., 2.19.x-dev], zendframework/zend-feed[2.12.0, 2.12.x-dev, 2.13.x-dev].
- Root composer.json requires drupal/ckeditor_config ^3.0 -> satisfiable by drupal/ckeditor_config[3.0.0-beta1, 3.0.0, 3.1.0, 3.x-dev].

My composer.json file looks like this:

    {
    "name": "drupal/recommended-project",
    "description": "Project template for Drupal 8 projects with a relocated document root",
    "type": "project",
    "license": "GPL-2.0-or-later",
    "homepage": "https://www.drupal.org/project/drupal",
    "support": {
        "docs": "https://www.drupal.org/docs/user_guide/en/index.html",
        "chat": "https://www.drupal.org/node/314178"
    },
    "repositories": [
        {
            "type": "path",
            "url": "web/modules/custom/*"
        },
        {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        }
    ],
    "require": {
        "composer/installers": "^1.2",
        "cweagans/composer-patches": "^1.7",
        "drupal/acl": "^1.0@beta",
        "drupal/admin_toolbar": "^3.1",
        "drupal/ckeditor_config": "^3.0",
        "drupal/config_inspector": "^1.3",
        "drupal/console": "^1.9",
        "drupal/content_access": "^1.0@alpha",
        "drupal/content_browser": "^1.0",
        "drupal/core-composer-scaffold": "^9.4",
        "drupal/core-project-message": "^9.4",
        "drupal/core-recommended": "^9.4",
        "drupal/csp": "^1.15",
        "drupal/d8w3css": "^2.0",
        "drupal/devel": "^5.0.0-beta1",
        "drupal/devel_entity_updates": "^4.0",
        "drupal/domain": "^1.0@beta",
        "drupal/domain_group": "^2.0",
        "drupal/domain_site_settings": "^1.3",
        "drupal/dropzonejs": "^2.4",
        "drupal/dynamic_entity_reference": "^1.12",
        "drupal/editor_advanced_link": "^1.8",
        "drupal/entity_browser": "^2.5",
        "drupal/entity_embed": "^1.1",
        "drupal/fancy_file_delete": "^2.0",
        "drupal/file_delete": "^1.0",
        "drupal/filefield_paths": "^1.0@beta",
        "drupal/formblock": "^2.0@beta",
        "drupal/gdoc_field": "^1.1",
        "drupal/group": "^1.5",
        "drupal/groupmedia": "^2.0@alpha",
        "drupal/ief_table_view_mode": "^2.2",
        "drupal/inline_entity_form": "^1.0@RC",
        "drupal/item_bucket": "*",
        "drupal/jsonapi_extras": "^3.19",
        "drupal/jsonapi_include": "^1.4",
        "drupal/libraries": "^3.0@beta",
        "drupal/media_bulk_upload": "^3.0",
        "drupal/media_directories": "^2.0",
        "drupal/media_entity_instagram": "^3.0",
        "drupal/multiple_fields_remove_button": "^1.0@alpha",
        "drupal/pathauto": "^1.8",
        "drupal/pdf": "^1.1",
        "drupal/profile": "^1.2",
        "drupal/rabbit_hole": "^1.0@beta",
        "drupal/responsive_menus": "^1.x-dev",
        "drupal/restui": "^1.20",
        "drupal/rules": "^3.0@alpha",
        "drupal/showcase_lite": "^1.3",
        "drupal/taxonomy_manager": "^2.0",
        "drupal/textarea_widget_for_text": "^1.2",
        "drupal/video_embed_spotify": "^1.5",
        "drupal/weight": "^3.3",
        "drush/drush": "^11",
        "kint-php/kint": "^4.2"
    },
    "conflict": {
        "drupal/drupal": "*"
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "config": {
        "sort-packages": true,
        "allow-plugins": {
            "composer/installers": true,
            "drupal/console-extend-plugin": true,
            "cweagans/composer-patches": true,
            "drupal/core-composer-scaffold": true,
            "drupal/core-project-message": true
        }
    },
    "extra": {
        "drupal-scaffold": {
            "locations": {
                "web-root": "web/"
            }
        },
        "installer-paths": {
            "web/core": [
                "type:drupal-core"
            ],
            "web/libraries/{$name}": [
                "type:drupal-library"
            ],
            "web/modules/contrib/{$name}": [
                "type:drupal-module"
            ],
            "web/profiles/contrib/{$name}": [
                "type:drupal-profile"
            ],
            "web/themes/contrib/{$name}": [
                "type:drupal-theme"
            ],
            "drush/Commands/contrib/{$name}": [
                "type:drupal-drush"
            ],
            "web/modules/custom/{$name}": [
                "type:drupal-custom-module"
            ],
            "web/themes/custom/{$name}": [
                "type:drupal-custom-theme"
            ]
        },
        "drupal-core-project-message": {
            "include-keys": [
                "homepage",
                "support"
            ],
            "post-create-project-cmd-message": [
                "<bg=blue;fg=white>                                                         </>",
                "<bg=blue;fg=white>  Congratulations, you’ve installed the Drupal codebase  </>",
                "<bg=blue;fg=white>  from the drupal/recommended-project template!          </>",
                "<bg=blue;fg=white>                                                         </>",
                "",
                "<bg=yellow;fg=black>Next steps</>:",
                "  * Install the site: https://www.drupal.org/docs/8/install",
                "  * Read the user guide: https://www.drupal.org/docs/user_guide/en/index.html",
                "  * Get support: https://www.drupal.org/support",
                "  * Get involved with the Drupal community:",
                "      https://www.drupal.org/getting-involved",
                "  * Remove the plugin that prints this message:",
                "      composer remove drupal/core-project-message"
            ]
        }
    }
}

I've tried individually updating each listed dependency, (ie composer update zendframework/zend-feed -W), etc, and they seem to run, but no updates are found and nothing is changing. How can I correct these dependency issues?

4
  • Please tell us the command you typed which resulted in the Problem 1 output above. Much of the output is drupal/core[8.9.11, ..., 8.9.x-dev] require php ^7.0.8 -> your php version (8.1.6) does not satisfy that requirement., which is obvious.
    – mona lisa
    Commented Sep 21, 2022 at 18:11
  • This is the result of running "$ composer update", with or without the -W (--with-all-dependencies) flag. Clearly it doesn't like the newer php, but I thought Drupal 9 is compatible with PHP 8+ so its surprising there is an issue or not an update to make everything compatible with Drupal 9, compatible with php8.
    – chickenug8
    Commented Sep 21, 2022 at 18:18
  • How did this site get into this situation? The composer.json you pasted above is not a valid JSON file so I can't test. Drupal 9 is fully compatible with PHP 8 but that doesn't mean the specific set of dependencies in that file and in the lockfile are compatible with PHP 8.
    – mona lisa
    Commented Sep 21, 2022 at 18:23
  • it's valid, the question formatting code/paragraph cut off the last "}". I'll edit the question.
    – chickenug8
    Commented Sep 21, 2022 at 18:26

1 Answer 1

1

The problem package is drupal/ckeditor_config. This is a packaging bug that is being discussed in these issues:

2
  • Yes, this is correct. It has affected many downstream modules that depend on this.
    – Kevin
    Commented Sep 21, 2022 at 18:43
  • Yeah, the "drupal/ckeditor_config": "^3.0" was the issue, thanks so much!
    – chickenug8
    Commented Sep 21, 2022 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.