9

I have installed CkEditor for drupal. But it is showing it for comment form also. I don't want it to be shown. I dont want the user to have an option to select either. I just want them to have plain text. How can I do that?

  • Notice that with the answers below you get exactly what you asked (plain text), but it's (in my opinion) better to have comments in Filtered HTML, so urls can be parsed into links, and you could allow other html in the future. So then it's a question of how to get Filtered HTML without the WYSIWYG editor. – arjan May 17 '12 at 11:28
12

Go to URL as in fig (for page comments on page content type). Change the type of text to Plain text as shown.
You can change the comment settings for article or book in similar way by just replacing page from the URL with the respective content types.

snapshot

2

The best and the most easy way is to go to the content type For example if the content type is "Articles" then go to Home » Administration » Structure » Content types » Article » Comment fields

And there in the comment field make sure it is set to plain text. And then there will be no problem and the user won't be asked to select a text format from the Drop down. As simple as that.

  • 1
    yes exactly what @Ajit showed... – Amitav Roy May 17 '12 at 12:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.