0

I have the subscription form of Simplenews in the footer, which should be protected with reCaptcha. I installed reCaptcha and created a captcha point with the form ID of the Simplenews block. Unfortunately, I don't see the recaptcha on the Simplenews registration block in the footer.

What am I doing wrong?

3
  • Does the issue also occur when using the Drupal default olivero/bartik theme?
    – No Sssweat
    Commented Jan 26, 2023 at 17:35
  • 1
    You need to log out. And you need the domain allowed in your reCaptcha settings on Google. Did you do both?
    – leymannx
    Commented Jan 26, 2023 at 18:07
  • 1
    Yes, the same issue with olivero/bartik theme. I also checked it on another browser which I wasn't logged in. I added reCaptcha on Google yesterday.
    – Zeroplexer
    Commented Jan 27, 2023 at 6:54

1 Answer 1

2

I was able to fix the problem. The ID of the form was too long. It seems that the ID can be a maximum of 64 characters long.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.