1

I have configured search API with autocomplete, the search box is exposed in a views block. But the block displays the default 5 results below the search box even if the box is not used yet. I want the search box only to be visible, not the content of the block. But i cant seem to set the number of displayed result to 0. Any idea?

search api live box

1 Answer 1

1

Under Exposed form Settings set the Exposed form style to Input required instead of Basic.

This will hold off showing any results until the user interacts with the form.

If the results are showing in the wrong region (for example below the Exposed form, instead of in the main content area) you probably didn't use the correct Block. Make sure your "Exposed form in block:" Setting is set to "Yes" to get a stand-alone Exposed form that can be placed in a different page region from the results.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.