1

I have a private group with private content which I set up with group visibility and group content visibility. Logged in as a non-member of this group I get access denied on the group page however when I enter the url of a node within that group I can see it fine.

I am using views cloned from the original OG views and I even tested it with the OG views and it is still allowing a non-member to see the nodes.

I have also rebuilt permissions a number of times.

I am unsure whether this is a bug in OG or a problem with my settings?

closed as too broad by kiamlaluno Jan 29 '16 at 8:01

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

1

Do you have any other access control modules installed? The access control mechanism assumes that only one module will be specifying the access control rules for nodes. Try disabling any modules like TAC, Workflow, etc. and see if that solves your problem.

  • I disabled Workflow Access and it all seems to work now. Thanks – Teegan May 21 '12 at 7:46
  • can you name a few more 'access control modules' ? how to check which modules are in control on a certain page ? – commonpike Jun 25 '13 at 8:53
3

I had a similar issue too. In the end, my mistake was having "group visibility" set as a field for the Post content type when it should have been "group content visibility."

0

the group page is by default viewable to only the group members. secondly in global or group permission it has a coloumn for members, this column settings provides the setting for all logined users and not just group members. so if your are using the global permission than i suggest u use group permissions , in group permisssions disable all check boxes for members now add role type in global or group roles and use this role to provide the access.

  • Could you be a little more specific? I went into global permissions and none of the permissions are enabled for member so I don't think that is it. Also none of these permissions deal with viewing only editing nodes. – Teegan May 21 '12 at 4:05
0

We had a similar issue. It was a conflict with Content Access and OG Access Control. After a bit of digging, Content Access has a weight option under it's advanced group. (The tab is found while editing Content Types).

Screen shot of the Access Control settings page on content types

So Kudos to the above answer of module conflict.

Note: We had to rebuild permissions by disabling and then later re-enabling Content Access.

0

I know this is a few years later, but I just went through this, too, and figured I'd add where my issue was for someone else. In my case the problem turned out to be an issue with the Taxonomy Tools module (even though I didn't have the taxonomy_role_access part enabled). Once I disabled it, my groups/group content began to act as expected.

Not the answer you're looking for? Browse other questions tagged or ask your own question.