0

I have Drupal 9.5 installed and running. I have uninstalled 3 deprecated modules (Aggregator, Color, and RDF). After that, I can't uninstall any module using the user interface. It gives the following error.

LogicException: Missing bundle entity, entity type comment_type, entity id comment. in Drupal\Core\Entity\EntityType->getBundleConfigDependency() (line 885 of web/core/lib/Drupal/Core/Entity/EntityType.php).

This error is linked to the Field Layout core module. The error shows when I try to uninstall that module. Rather showing the confirmation, it shows the error. Then, whatever module I try to uninstall, it shows the same error.

So I re-installed the RDF module. After some time (I don't know what I did), I can see the uninstall confirmation page for modules. When I try to uninstall the Field Layout module, it shows the error, which is shown also for other modules.

The site is working okay, but uninstalling modules is not possible. I can uninstall modules using Drush. I ran drush cr and drush updb, but that error is still shown.

Could anyone help me?

1

1 Answer 1

3

I don't think it's possible to reproduce this uninstalling and installing of unrelated modules.

The error message itself says the comment type comment is missing. This is part of the standard profile and could be easily recreated, either in UI /admin/structure/comment or by importing:

web/core/profiles/standard/config/install/comment.type.comment.yml

langcode: en
status: true
dependencies: {  }
id: comment
label: 'Default comments'
target_entity_type_id: node
description: 'Allows commenting on content'

Goto /admin/config/development/configuration/single/import, select the configuration type "Comment type" and paste the configuration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.