-4

I'm running Drupal 9.59. I tried following the instructions on drupal.org for upgrading to Drupal 10. The steps with composer --no-update went fine. The actual update step yields:

Loading composer repositories with package information
Info from https://repo.packagist.org: #StandWithUkraine
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

Problem 1

  • drupal/core 8.0.0-beta6 requires doctrine/common dev-master#a45d110f71c323e29f41eb0696fa230e3fa1b1b5 -> found doctrine/common[dev-remove-int-cast, 2.1.3, ..., 2.13.x-dev, 3.0.0, ..., 3.5.x-dev] but it does not match the constraint.
  • drupal/core[8.0.0-beta13, ..., 8.0.0-beta15] require guzzlehttp/guzzle dev-master#1879fbe853b0c64d109e369c7aeff09849e62d1e -> found guzzlehttp/guzzle[v1.0.3, v1.0.4, v2.0.0, ..., v2.8.8, v3.0.0, ..., v3.8.1, 4.0.0-rc.1, ..., 4.x-dev, 5.0.0, ..., 5.3.x-dev, 6.0.0, ..., 6.5.x-dev, 7.0.0-beta.1, ..., 7.7.x-dev] but it does not match the constraint.
  • zendframework/zend-feed[dev-master, dev-develop, 2.11.0, ..., 2.13.x-dev] require php ^5.6 || ^7.0 -> your php version (8.1.16) does not satisfy that requirement.
  • laminas/laminas-feed[2.12.0, ..., 2.12.x-dev] require php ^5.6 || ^7.0 -> your php version (8.1.16) does not satisfy that requirement.
  • symfony/psr-http-message-bridge[v1.1.0, ..., 1.1.x-dev] require php ^5.3.3 || ^7.0 -> your php version (8.1.16) does not satisfy that requirement.
  • symfony-cmf/routing[1.4.0-RC1, ..., 1.4.x-dev] require php ^5.3.9|^7.0 -> your php version (8.1.16) does not satisfy that requirement.
  • symfony/psr-http-message-bridge[v1.2.0, ..., v1.3.0] require php ^7.1 -> your php version (8.1.16) does not satisfy that requirement.
  • drupal/core[8.9.11, ..., 8.9.x-dev] require php ^7.0.8 -> your php version (8.1.16) does not satisfy that requirement.
  • drupal/core[9.0.10, ..., 9.0.x-dev] require php ^7.3 -> your php version (8.1.16) does not satisfy that requirement.
  • laminas/laminas-feed[2.13.0, ..., 2.14.x-dev] require php ^7.3 || ~8.0.0 -> your php version (8.1.16) does not satisfy that requirement.
  • Root composer.json requires drupal/token_filter ^1.4 -> satisfiable by drupal/token_filter[1.4.0, 1.x-dev].
  • drupal/core-recommended 10.0.0-alpha1 requires drupal/core 10.0.0-alpha1 -> satisfiable by drupal/core[10.0.0-alpha1].
  • Conclusion: don't install drupal/core 10.0.0-alpha1 (conflict analysis result)
  • drupal/core-recommended 10.0.0-alpha2 requires drupal/core 10.0.0-alpha2 -> satisfiable by drupal/core[10.0.0-alpha2].
  • Conclusion: don't install drupal/core 10.0.0-alpha2 (conflict analysis result)
  • drupal/core-recommended 10.0.0-alpha3 requires drupal/core 10.0.0-alpha3 -> satisfiable by drupal/core[10.0.0-alpha3].
  • Conclusion: don't install drupal/core 10.0.0-alpha3 (conflict analysis result)
  • drupal/core-recommended 10.0.0-alpha4 requires drupal/core 10.0.0-alpha4 -> satisfiable by drupal/core[10.0.0-alpha4].
  • Conclusion: don't install drupal/core 10.0.0-alpha4 (conflict analysis result)
  • drupal/core-recommended 10.0.0-alpha5 requires drupal/core 10.0.0-alpha5 -> satisfiable by drupal/core[10.0.0-alpha5].
  • Conclusion: don't install drupal/core 10.0.0-alpha5 (conflict analysis result)
  • drupal/core-recommended 10.0.0-alpha6 requires drupal/core 10.0.0-alpha6 -> satisfiable by drupal/core[10.0.0-alpha6].
  • Conclusion: don't install drupal/core 10.0.0-alpha6 (conflict analysis result)
  • drupal/core-recommended 10.0.0-alpha7 requires drupal/core 10.0.0-alpha7 -> satisfiable by drupal/core[10.0.0-alpha7].
  • Conclusion: don't install drupal/core 10.0.0-alpha7 (conflict analysis result)
  • drupal/core-recommended 10.1.0-alpha1 requires drupal/core 10.1.0-alpha1 -> satisfiable by drupal/core[10.1.0-alpha1].
  • Conclusion: don't install drupal/core 10.1.0-alpha1 (conflict analysis result)
  • drupal/core-recommended 10.0.0-beta1 requires drupal/core 10.0.0-beta1 -> satisfiable by drupal/core[10.0.0-beta1].
  • Conclusion: don't install drupal/core 10.0.0-beta1 (conflict analysis result)
  • drupal/core-recommended 10.0.0-beta2 requires drupal/core 10.0.0-beta2 -> satisfiable by drupal/core[10.0.0-beta2].
  • Conclusion: don't install drupal/core 10.0.0-beta2 (conflict analysis result)
  • drupal/core-recommended 10.1.0-beta1 requires drupal/core 10.1.0-beta1 -> satisfiable by drupal/core[10.1.0-beta1].
  • Conclusion: don't install drupal/core 10.1.0-beta1 (conflict analysis result)
  • drupal/core-recommended 10.0.0-rc1 requires drupal/core 10.0.0-rc1 -> satisfiable by drupal/core[10.0.0-rc1].
  • Conclusion: don't install drupal/core 10.0.0-rc1 (conflict analysis result)
  • drupal/core-recommended 10.0.0-rc2 requires drupal/core 10.0.0-rc2 -> satisfiable by drupal/core[10.0.0-rc2].
  • Conclusion: don't install drupal/core 10.0.0-rc2 (conflict analysis result)
  • drupal/core-recommended 10.0.0-rc3 requires drupal/core 10.0.0-rc3 -> satisfiable by drupal/core[10.0.0-rc3].
  • Conclusion: don't install drupal/core 10.0.0-rc3 (conflict analysis result)
  • drupal/core-recommended 10.1.0-rc1 requires drupal/core 10.1.0-rc1 -> satisfiable by drupal/core[10.1.0-rc1].
  • Conclusion: don't install drupal/core 10.1.0-rc1 (conflict analysis result)
  • drupal/core-recommended 10.0.0 requires drupal/core 10.0.0 -> satisfiable by drupal/core[10.0.0].
  • Conclusion: don't install drupal/core 10.0.0 (conflict analysis result)
  • drupal/core-recommended 10.0.1 requires drupal/core 10.0.1 -> satisfiable by drupal/core[10.0.1].
  • Conclusion: don't install drupal/core 10.0.1 (conflict analysis result)
  • drupal/core-recommended 10.0.2 requires drupal/core 10.0.2 -> satisfiable by drupal/core[10.0.2].
  • Conclusion: don't install drupal/core 10.0.2 (conflict analysis result)
  • drupal/core-recommended 10.0.3 requires drupal/core 10.0.3 -> satisfiable by drupal/core[10.0.3].
  • Conclusion: don't install drupal/core 10.0.3 (conflict analysis result)
  • drupal/core-recommended 10.0.4 requires drupal/core 10.0.4 -> satisfiable by drupal/core[10.0.4].
  • Conclusion: don't install drupal/core 10.0.4 (conflict analysis result)
  • drupal/core-recommended 10.0.5 requires drupal/core 10.0.5 -> satisfiable by drupal/core[10.0.5].
  • Conclusion: don't install drupal/core 10.0.5 (conflict analysis result)
  • drupal/core-recommended 10.0.6 requires drupal/core 10.0.6 -> satisfiable by drupal/core[10.0.6].
  • Conclusion: don't install drupal/core 10.0.6 (conflict analysis result)
  • drupal/core-recommended 10.0.7 requires drupal/core 10.0.7 -> satisfiable by drupal/core[10.0.7].
  • Conclusion: don't install drupal/core 10.0.7 (conflict analysis result)
  • drupal/core-recommended 10.0.8 requires drupal/core 10.0.8 -> satisfiable by drupal/core[10.0.8].
  • Conclusion: don't install drupal/core 10.0.8 (conflict analysis result)
  • drupal/core-recommended 10.0.9 requires drupal/core 10.0.9 -> satisfiable by drupal/core[10.0.9].
  • Conclusion: don't install drupal/core 10.0.9 (conflict analysis result)
  • drupal/core-recommended 10.1.0 requires drupal/core 10.1.0 -> satisfiable by drupal/core[10.1.0].
  • Conclusion: don't install drupal/core 10.1.0 (conflict analysis result)
  • drupal/core[8.4.0-alpha1, ..., 8.7.7] require symfony-cmf/routing ^1.4 -> satisfiable by symfony-cmf/routing[1.4.0-RC1, ..., 1.4.x-dev].
  • drupal/core[8.2.0-beta1, ..., 8.3.x-dev] require symfony-cmf/routing ~1.4 -> satisfiable by symfony-cmf/routing[1.4.0-RC1, ..., 1.4.x-dev].
  • drupal/core[9.0.0-alpha1, ..., 9.0.0-alpha2] require symfony/psr-http-message-bridge ^1.2.0 -> satisfiable by symfony/psr-http-message-bridge[v1.2.0, v1.3.0].
  • drupal/core[8.7.8, ..., 8.9.10] require symfony/psr-http-message-bridge ^1.1.2 -> satisfiable by symfony/psr-http-message-bridge[v1.1.2, 1.1.x-dev, v1.2.0, v1.3.0].
  • drupal/core[8.8.0-alpha1, ..., 8.8.x-dev] require zendframework/zend-feed ^2.12 -> satisfiable by laminas/laminas-feed[2.12.0, ..., 2.21.x-dev], zendframework/zend-feed[2.12.0, 2.12.x-dev, 2.13.x-dev].
  • drupal/core-recommended 10.1.x-dev requires drupal/core 10.1.x-dev -> satisfiable by drupal/core[10.1.x-dev].
  • Conclusion: don't install drupal/core 10.1.x-dev (conflict analysis result)
  • drupal/token_filter[1.4.0, ..., 1.x-dev] require drupal/core ^8 || ^9 -> satisfiable by drupal/core[8.0.0-beta6, ..., 8.9.x-dev, 9.0.0-alpha1, ..., 9.5.x-dev].
  • You can only install one version of a package, so only one of these can be installed: drupal/core[8.0.0-beta6, ..., 8.9.x-dev, 9.0.0-alpha1, ..., 9.5.x-dev, 10.0.0-alpha1, ..., 10.1.x-dev].
  • You can only install one version of a package, so only one of these can be installed: drupal/core[8.0.0-beta12, ..., 8.9.x-dev, 9.0.0-alpha1, ..., 9.5.x-dev, 10.0.0-alpha1, ..., 10.1.x-dev].
  • You can only install one version of a package, so only one of these can be installed: drupal/core[8.1.2, ..., 8.9.x-dev, 9.0.0-alpha1, ..., 9.5.x-dev, 10.0.0-alpha1, ..., 10.1.x-dev].
  • You can only install one version of a package, so only one of these can be installed: drupal/core[8.1.8, ..., 8.9.x-dev, 9.0.0-alpha1, ..., 9.5.x-dev, 10.0.0-alpha1, ..., 10.1.x-dev].
  • You can only install one version of a package, so only one of these can be installed: drupal/core[8.7.0-alpha1, ..., 8.9.x-dev, 9.0.0-alpha1, ..., 9.5.x-dev, 10.0.0-alpha1, ..., 10.1.x-dev].
  • drupal/core-recommended 10.0.x-dev requires drupal/core 10.0.x-dev -> satisfiable by drupal/core[10.0.x-dev].
  • Root composer.json requires drupal/core-recommended ^10 -> satisfiable by drupal/core-recommended[10.0.0-alpha1, ..., 10.1.x-dev].

composer [update] failed, composer command failed: exit status 2. stderr=

I'm stumped. I tried removing the lock file, but no difference.

2 Answers 2

2

I would start by fixing each issue, starting with “drupal/token_filter[1.4.0, ..., 1.x-dev] require drupal/core ^8 || ^9”.

As far as I know all upgrade guides recommend updating contributed modules first and using readiness reports.

4
  • Except the main one, so far. drupal.org/docs/upgrading-drupal/…
    – JAyenGreen
    Commented Jul 3, 2023 at 13:30
  • The doc says to begin with composer require 'drupal/core-recommended:^10' 'drupal/core-composer-scaffold:^10' 'drupal/core-project-message:^10' --update-with-dependencies --no-update, then composer require 'drupal/recommended-project:^10' --update-with-dependencies --no-update, after which it says drupal/recommended-project cannot require itself in composer.json.
    – JAyenGreen
    Commented Jul 3, 2023 at 13:39
  • 1
    The overview of that docs section says to upgrade contributed projects, first thing: drupal.org/docs/upgrading-drupal/…
    – mona lisa
    Commented Jul 3, 2023 at 15:26
  • That last statement couldn't be more important - I just went through this process on a large, complex site yesterday. Making sure that everything was at latest versions, and updating constraints for contrib modules with a release only for D10 (not 9&10) were represented, e.g. ^2.0 || ^3.0, made everything go smoothly
    – Clive
    Commented Jul 3, 2023 at 15:53
-1

I would recommend doing a composer update drupal/core-recommended -W (with all dependencies). Seems the guzzle items aren't marked for update. Also make sure your contributed modules are updated to the latest versions as well. Also a nice composer why-not drupal/core-recommended:^10 may give more information. Finally if that doesn't work, install drupal/upgrade_status and run a report which may tell more.

4
  • Upgrade_status declared almost all being well other than fontyourface and stable. That might be part of what has me hosed…my theme uses stable as its base. I just tried stable9 and that was no good. This might get painful.
    – JAyenGreen
    Commented Jul 3, 2023 at 15:46
  • drupal.org/project/stable is a drop-in replacement for core stable. Literally tested it yesterday and works a treat, you just need to install it in the D9 site first, part of the "upgrade contributed projects first" requirement that cilefen mentioned in comments on the other answer
    – Clive
    Commented Jul 3, 2023 at 15:50
  • I've gone through and updated or removed all until upgrade status is all green. When I try to update to 10.1.1 (composer require drupal/core-recommended:^10.1.1 drupal/core-composer-scaffold:^10.1.1 drupal/core-project-message:^10.1.1 --update-with-all-dependencies) I get "...require psr/container ~2.0.2 -> found psr/container[dev-master, 2.0.2, 2.0.x-dev] but these were not loaded, likely because it conflicts with another require"
    – JAyenGreen
    Commented Jul 9, 2023 at 3:06
  • Cilifen's answer ultimately got me to the correct place. To get upgrade_status to all be green, some modules (eg fontyourface) needed to be removed. Removing the lock file and the vendor folder helped too. I tried using 10.1.1 on the update command, as mentioned above, but that put me into that psr hell. Changing it back to simply ^10 ultimately worked.
    – JAyenGreen
    Commented Jul 9, 2023 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.