0

I have a few webforms on my D9 site. They all work for anonymous site visitors except for the contact form, which gives an "access denied" error.

The permissions under the form's Settings->Access tab are the same as for other forms that do work.

The form's access permissions are set to allow anonymous / authenticated / admin users to create and view/ update own submissions: Create submissions: Roles: anonymous user, authenticated user, administrator

View/ Update Own Submissions: anonymous, authenticated, administrator

I did search for the solution but what I found didn't help. I tried the debugging code from https://drupal.stackexchange.com/a/315766 and get the following messages:

The website encountered an unexpected error. Please try again later.

Exception: ACCESS DENIED: in Symfony\Component\HttpKernel\Exception\AccessDeniedHttpException->__construct() (line 28 of /path/to/vendor/symfony/http-kernel/Exception/AccessDeniedHttpException.php).

Drupal\Core\Http\Exception\CacheableAccessDeniedHttpException->__construct() (Line: 118)
Drupal\Core\Routing\AccessAwareRouter->checkAccess() (Line: 95)
Drupal\Core\Routing\AccessAwareRouter->matchRequest() (Line: 112)
Symfony\Component\HttpKernel\EventListener\RouterListener->onKernelRequest()
call_user_func() (Line: 142)
Drupal\Component\EventDispatcher\ContainerAwareEventDispatcher->dispatch() (Line: 145)
Symfony\Component\HttpKernel\HttpKernel->handleRaw() (Line: 81)
Symfony\Component\HttpKernel\HttpKernel->handle() (Line: 58)
Drupal\Core\StackMiddleware\Session->handle() (Line: 48)
Drupal\Core\StackMiddleware\KernelPreHandle->handle() (Line: 191)
Drupal\page_cache\StackMiddleware\PageCache->fetch() (Line: 128)
Drupal\page_cache\StackMiddleware\PageCache->lookup() (Line: 82)
Drupal\page_cache\StackMiddleware\PageCache->handle() (Line: 48)
Drupal\Core\StackMiddleware\ReverseProxyMiddleware->handle() (Line: 51)
Drupal\Core\StackMiddleware\NegotiationMiddleware->handle() (Line: 23)
Stack\StackedHttpKernel->handle() (Line: 718)
Drupal\Core\DrupalKernel->handle() (Line: 19)

I don't know what this all means. Where do I go from here? Thank you.

6
  • Is this relevant? drupal.org/project/webform/issues/3157367
    – cilefen
    Jul 20, 2023 at 17:41
  • Unfortunately, no. I don't have anything set in the submission limit settings. Thanks tho
    – leeksoup
    Jul 21, 2023 at 5:14
  • Unfortunately the Drupal 8 version of Webform is no longer supported, and neither is Drupal 8 for that matter. You could install a new site on your own dev platform or with simplytest.me, export the configurations of the forms and diff the exports. That is what I would do, faced with this issue.
    – cilefen
    Jul 21, 2023 at 11:22
  • I'm in the process of updating the site to D9 and so far I'm still seeing the same problem. I will try what you suggest. Thanks.
    – leeksoup
    Jul 23, 2023 at 4:26
  • Updated with D9 info. Confirmed the problem is still happening. I will try the config exports next.
    – leeksoup
    Jul 24, 2023 at 23:01

1 Answer 1

0

This is probably due to submission limits, as laid out by the module maintainer.

You need to uncheck 'Limit total to one submission per webform/source entity' (/admin/structure/webform/manage/contact/settings/submissions) and set [the] submission limit to 1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.