1

I've found a way to add a style to a region. The link is /admin/structure/ds/styles.

I've found a way to specify a style for my Title. We can choose the "class" attribute of title property.

Howe can I add a specific class/span to my "publish date" field?

How can I do that with Display Suite?

3
  • I think "admin/structure/ds/extras" can help me, but I don't know how to use it. Link/tutorials/Help is welcome :)
    – user117283
    May 20, 2012 at 16:48
  • 2
    DS Extra module do the trick. Choose "expert" mode for field, and play with it.
    – user117283
    May 20, 2012 at 18:17
  • Play with it?.....Isn't there a propper tutorial for this, "playing wiith it" is a waste of a lot of time...! Mar 24, 2016 at 2:43

1 Answer 1

0
  1. Enable the module display suite extras
  2. Define a display suite layout. Once the layout is specified you get the 'custom classes tab'.
  3. Enable Field Templates in the display suite configuration screen admin > structure > Display Suite. Then select "Field Templates". Check "Enable Field Templates. URL is admin/structure/ds/list/extras
  4. Define some classes. Using the "CSS classes" tab in the display suite settings define some "CSS classes for fields". URL is admin/structure/ds/classes
  5. Ensure that the view mode that you are using is managed by display suite. Under "Manage display" accessed either via the node editing screen or admin > structure > content types check the box next to the view mode being used. In the format column the 'Field template' text should now be shown.
  6. Using the cog icon on the right, edit the field template setting. Select the CSS style chosen in #4

With images the process is 1. enable display suite extras 2. Define a display suite layout

define a display suite layout

  1. Enable field templates Enable field templates

  2. Define classes Define classes

  3. Manage the view mode

Manage the view mode

  1. Select the classes

Display suite is now managing the format

Display suite select classes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.