1

I'm using Drupal 7.97 with these modules:

  • Views 4.25
  • Rules 2.13
  • Webform rules 1.6

Recently I upgraded Drupal to 7.97 and Views to 4.x branch, After that my rule that sends email to anyone who submitted the webform stopped working.

My rule reacts on the event "After a webform has been submitted" and should fire the action: "Send email" to <?php print $data['components']['email']['value'][0]; ?>.

email above is my email field from Webform "Contact".

I've debugged this variable: $data['components']['email']['value'][0] and it contains proper email after submitting the form.

But in dblog I've found the message: Error sending e-mail (from [email protected] to ).

What I've tried:

Here is my rule export

{ "rules_after_submitting_contact_form" : {
    "LABEL" : "After submitting contact form",
    "PLUGIN" : "reaction rule",
    "OWNER" : "rules",
    "TAGS" : [ "After submitting contact form" ],
    "REQUIRES" : [ "php", "rules", "webform_rules" ],
    "ON" : { "webform_rules_submit" : [], "webform_rules_submit_as_draft" : [] },
    "DO" : [
      { "mail" : {
          "to" : "\u003C?php print $data[\u0027components\u0027][\u0027email\u0027][\u0027value\u0027][0]; ?\u003E",
          "subject" : "information",
          "message" : "Thank you for submitting contact form",
          "from" : "[email protected]",
          "language" : [ "" ]
        }
      }
    ]
  }
}

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.