0

In a view I am displaying a list of nodes with their authors. The authors are displayed as an entity with a certain view mode, which includes a flag on the user/author. People can flag the author of a certain node. Works fine. The node also has other users referenced (team members), they are also displayed with their flag. Works fine.

What does not work fine, is the use of Views Conditional to check if one of the additional User has a certain tag and if yes, then only show this user. The Condition works well, the right user is displayed, BUT the flag is not parsed through the Views Conditional field.

And whats even more curios. In the views preview it is parsed, but not in the frontend (no matter if I am logged in as admin or not).

Checked by now: Any templating reasons in my theme are not the cause Permission reasons are not the cause most likely (dont see it as admin either)

Any idea on why or any hint to a workaround is highly welcome. thanks in advance!!

2
  • I know there was/is an issue if you have the same entity showing multiple times, the flag only renders once. It could be that, or if the flag on none of them? Sep 6, 2023 at 14:40
  • tried it with hiding the user with the flag before the views condition, but still the same. flag wont be rendered through views condition in the frontend. it still renders within the view preview thou.
    – Matthias
    Sep 6, 2023 at 15:38

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.