2

How can I resolve this issue? This log issue occurs in Drupal 10.0.10, Drush 12.2.0 PHP 8.1 Everything seemed fine when I had upgraded to D10 all the sites were working fine, All of sudden its starting to throw this error when I had cleared cache.

I tried resolving it deleting the vendor and composer lock and then running a composer update it did not work.

I am assuming the issue is caused by Blazy module. I hope I am correct. I tried to remove the module and but its dependency modules are failing to delete.

0-php-errors.log                                                                     
Uncaught PHP Exception Error: "Class "\Drupal\text\Plugin\Field\FieldType\TextFieldItemList" not found" at /mnt/www/html/Development/docroot/core/lib/Drupal/Core/TypedData/TypedDataManager.php line 91 request_id="v-82976780-5dd8-11ee-8de8-b7f4d9badddd"
 Uncaught PHP Exception Drupal\Component\Plugin\Exception\PluginNotFoundException: "The "filter_image_lazy_load" plugin does not exist. Valid plugin IDs for Drupal\filter\FilterPluginManager are: blazy_filter, editor_file_reference, entity_embed, filter_align, filter_autop, filter_caption, filter_html, filter_htmlcorrector, filter_html_escape, filter_html_image_secure, filter_null, filter_url, media_embed, filter_responsive_tables_filter, slick_filter, video_embed_wysiwyg" at /mnt/www/html/Development/docroot/core/lib/Drupal/Component/Plugin/Discovery/DiscoveryTrait.php line 53 request_id="v-2aa6af7a-5dda-11ee-a334-e7cbdc62d936"
8
  • 1
    Obtain stack traces. Add them to the Question. This question is rather vague as it is currently written.
    – cilefen
    Sep 29, 2023 at 3:42
  • Also, what is unclear about the error message, the filter_image_lazy_load plugin is missing, those plugins are usually configured and should be easily found in a config export? You can either remove it from the config or install a module providing the filter plugin.
    – 4uk4
    Sep 29, 2023 at 7:23
  • @4uk4 could you please suggest me how can I do this "You can either remove it from the config or install a module providing the filter plugin" I have never do this before? Sep 29, 2023 at 7:27
  • Goto /admin/config/development/configuration/full/export, download the full configuration, then search for the machine name of the missing filter. You can also search in the code of modules you had installed to find the module providing this filter.
    – 4uk4
    Sep 29, 2023 at 7:31
  • The odd thing, this filter is a D10 core filter installed by default.
    – 4uk4
    Sep 29, 2023 at 7:37

1 Answer 1

2

I had the same issue rolling back from Drupal 10.1.4 to 9.5.11. You can get the conflicting config with this cmd drush cget filter.format.basic_html filters.filter_image_lazy_load then you will be able to remove from DB with drush cdel filter.format.basic_html filters.filter_image_lazy_load

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.