1

Since I updated my site to Drupal 9.5.11, 'index.php/' is added to every URL: http://mysite.org/index.php/ for the home page, for example.

On some page, I have a list with links to files and, because of this strange behavior, links lead to a 'Page not found' error. In this case, 'index.php/' is even added twice: http://mysite.org/index.php/index.php/system/files/contracts/Contract-228-20231108.pdf.

I found some posts about similar issues but the main difference with these posts is that in my case, the behavior occurs when the user is authenticated. No problem for anonymous visitors!

Other clue (maybe?): it occurs in my Production site and everything is OK on my local site (managed with MAMP).

Any idea what is going wrong?

1 Answer 1

3

It is floating core bug. See this issue

The answer which helps me:

Install redirect module and enable "Enforce clean and canonical URLs" then clear cache.

1
  • Installed Redirect and it seems to work. Thanks!
    – gbmapo
    Commented Oct 2, 2023 at 12:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.