2

I have a new install of Drupal 10 with CKEditor 5 enabled, and I thought that CKEditor 5 now provided autocompletion of links, as used to be provided by the Linkit module. However, whenever I try to use the Link button, I get the 'Link URL' box shown below, but never any autocompletion suggestions no matter how many characters I type.

What is the correct method to get this working?

2
  • Are there browser console errors?
    – mona lisa
    Oct 10, 2023 at 22:32
  • @cilefen yes there are I have added them to the post Oct 10, 2023 at 22:38

1 Answer 1

3

At the time I write this, it is necessary to install and enable LinkIt on desired text formats in Drupal 10 to enable this feature. Yes, there is a Core issue to bring LinkIt features into Core but that is incomplete.

4
  • I was afraid you were going to say that, as I cannot get LinkIt to work either... the Linkit button never appears in CKEditor. I will open a separate question for this! Thanks for your input. Oct 10, 2023 at 22:58
  • 1
    There is no linkit button. You enable it on the text format. It enhances the default button.
    – mona lisa
    Oct 10, 2023 at 23:41
  • I have now uninstalled and reinstalled Linkit and got it working. I think that previously I was using the wrong text format to edit the text, a text format which had not had a Linkit profile enabled. All working now. Thank you for your time. Oct 10, 2023 at 23:44
  • (There was historically a separate Linkit button for the editor, which confused me when searching the documentation.) Oct 10, 2023 at 23:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.