3

I'm installing a local instance of Drupal 7 on my WinXp machine. PHP 5.4 and MySql 5.5 are installed already.

I've unpacked the downloaded Drupal 7 site files into a virtual directory and used IIS 6 to make this directory a PHP site.

However, the result is not encouraging:

CGI Error The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:

Could not open input file: Files\PHP\php-win.exe

The web address I'm using is:

http://localhost/drupal7/install.php

Where "drupal7" is the name of my application in IIS.

Any ideas on what the problem might be?

| improve this question | | | | |
  • 1
    If possible I'd switch to Apache instead of IIS – Johnathan Elmore May 21 '12 at 22:57
  • Apache on Windows? Hmmm. Can you even run Apache and IIS on the same machine? – Mike Clark May 21 '12 at 23:05
  • Yuppers. httpd.apache.org/download.cgi#apache24 I do all my development with Apache 2.4, PHP 5.3 and MySQL 5.5 on Windows XP. – Johnathan Elmore May 21 '12 at 23:14
  • Use XAMP, WAMP... – Nikit May 22 '12 at 0:23
  • 1
    @Ajit, you should put this comment into the question as an Answer. I just got done installing Acquia Dev Desktop and got my Drupal site up and running with no problems whatsoever. I'd like to Accept your comment as the Accepted Answer if I could. – Mike Clark May 22 '12 at 17:14
1

As in my comment above, you should try using WAMP server or Acquia Dev Desktop, which uses Apache (more suitable for PHP development).

To install Drupal on Windows, you could install it with Microsoft web platform installer by following this procedure.

| improve this answer | | | | |
0

Commenters are right : try to use Apache.

About your error, my guess is a there is a path problem with the "Program Files" folder which contains a space which must not have been escaped correctly.

Did you try to change the place of your installation and/or correct the setting for the path to the php executable ?

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.