-1

Drush Launcher gives an error in an environment updated to Drupal 10.2. The environment is Drupal 10.2, PHP 8.2, Drush 12.4, Drush Launcher 0.10.2. Specifically, I get the following error

[user@host drupal]$ drush status
The Drush launcher could not find a local Drush in your Drupal site.
Please add Drush with Composer to your project.
Run 'cd "/var/www/drupal" && composer require drush/drush'

However, Drush is installed by composer and is also listed in composer.json. I have updated from Drupal 9, but I can no longer run the Drush command with only "drush". I would like to be able to run it with "drush" instead of "vendor/bin/drush". ./bashrc or any other method other than passing it through $PATH, please. The following from Drupal 9 is ideal.

[user@host drupal]$ drush status
...
Drush script     : /usr/local/bin/drush
...

Please help.

5
  • 1
    This repository has been archived by the owner on Aug 19, 2023. It is now read-only. github.com/drush-ops/drush-launcher
    – leymannx
    Feb 5 at 11:22
  • Check some alternatives here: github.com/drush-ops/drush-launcher/issues/105.
    – leymannx
    Feb 5 at 11:25
  • I changed my mind about closing this question. It has a factual answer.
    – cilefen
    Feb 5 at 13:52
  • So Drush Launcher is not compatible with Drupal 10 and Drush 12, so there is no other way but to use it through $PATH?
    – Skyyade
    Feb 6 at 1:32
  • Incorrect. Read the defunct project’s page for alternatives, as I wrote in the answer.
    – cilefen
    Feb 6 at 10:55

1 Answer 1

0

drush-launcher does not work because it is unmaintained. See its archived project page for alternatives.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.