0

I am following the instructions for making a patch at:

https://www.drupal.org/docs/develop/git/using-git-to-contribute-to-drupal/working-with-patches/making-a-patch

The module and release I am attempting to patch is https://www.drupal.org/project/infogram/releases/2.0.0

Step 5 of the instructions for making a patch say to do...

git diff origin/BASE_VERSION

I have tried the following:

git diff origin/2.0.0
git diff origin/2.0
git diff origin/2.0.x-dev

In all cases, I see messages like...

fatal: ambiguous argument 'origin/2.0.0': unknown revision or path not in the working tree.

What is the correct BASE_VERSION if I am trying to patch infogram 2.0.0?

(Note: 2.0.0 is identical to 2.0.x-dev at the moment, so I'm not sure it matters if I target 2.0.0 or 2.0.x-dev.)

  • The git version is 2.39.1.windows.1
  • The Drupal version is 10.1.6
2
  • 1
    Just use 2.0.0, drop the origin.
    – Jaypan
    Feb 14 at 15:09
  • Yes. ^ Tags don't have branches. This isn't a Drupal question.
    – cilefen
    Feb 14 at 16:28

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.