0

My content type has the following settings for body field in "Manage display" tab, for "Teaser" display mode: Label: Hidden; Format: Summary or Trimmed, Trim length: 2000

However, the summary is never actually displayed in Teaser mode, only trimmed body.

For example, in node edit form, after clicking Preview, the Teaser preview clearly displays an automatically truncated beginning of the body. The summary was entered, but is not displayed in preview.

The same in a View, the format is set to show Content, Teaser. Again, the summary is not taken into account, only the body field.

What to check, how to fix this??

0

In the Manage Display settings for the content type, choose 'Summary or Trimmed' this way if a summary is provided it will display that. Otherwise it will display a trimmed version of the body.

You can download other formatters, i.e one that will strip tags and trim on a word boundary. By default the trimmed function will always split on a paragraph.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.