0

I am stuck on how to update Drupal to 10.2.x and Open Social (goalgorilla/open_social) to the latest compatible version (12.3.2 or 12.2.4) using composer.

I've looked at the open social docs on how to update, but they do not help.

This is as far as I've got:

  1. In the composer.json I changed: "drupal/core-recommended" to "~10.2.0" and "drush/drush" to "*"
  2. I then ran: composer update drupal/core-recommended:~10.2.5 drupal/core:~10.2.5 drush/drush goalgorilla/open_social:^12.3.2 -W. I included core-recommended, core, and drush as composer was giving errors saying that updates to these packages were not requested.
  3. This is the error I have from this command:
Problem 1
    - Root composer.json requires drupal/core-recommended ~10.2.0 -> satisfiable by drupal/core-recommended[10.2.5, 10.2.x-dev].
    - goalgorilla/open_social[12.3.2, ..., 12.4.x-dev] require drupal/swiftmailer 2.3.0 -> satisfiable by drupal/swiftmailer[2.3.0].
    - Conclusion: don't install drupal/swiftmailer 2.3.0 (conflict analysis result)
    - Root composer.json requires goalgorilla/open_social ^12.0.0-rc6 -> satisfiable by goalgorilla/open_social[12.3.2, 12.3.x-dev, 12.4.x-dev].

This is my composer.json, which may help you:

{
    "name": "goalgorilla/social_template",
    "description": "Social project template for composer based Open Social projects.",
    "type": "project",
    "license": "GPL-2.0+",
    "minimum-stability": "dev",
    "prefer-stable": true,
    "require": {
        "goalgorilla/open_social": "^12.0.0-rc6",
        "php": "^8.1",
        "monolog/monolog": "^2.3.5",
        "drush/drush": "^11.5",
        "drupal/shield": "^1.7",
        "drupal/webform": "^6.2",
        "drupal/key": "^1.17",
        "drupal/salesforce": "^5.0",
        "firebase/php-jwt": "^6.5",
        "drupal/features": "^3.13",
        "drupal/core-recommended": "~10.0.0",
        "platformsh/config-reader": "^2.4",
        "composer/installers": "^2.0",
        "drupal/redis": "^1.6",
        "drupal/config_modify": "^1.1",
        "drupal/symfony_mailer": "^1.4",
        "drupal/jquery_ui_autocomplete": "^2.0"
    },
    "repositories": [
        {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        },
        {
            "type": "composer",
            "url": "https://asset-packagist.org"
        }
    ],
    "extra": {
        "drupal-scaffold": {
            "locations": {
                "web-root": "html/"
            }
        },
        "installer-types": [
            "bower-asset",
            "npm-asset"
        ],
        "installer-paths": {
            "html/core": [
                "drupal/core"
            ],
            "html/modules/contrib/{$name}": [
                "type:drupal-module"
            ],
            "html/profiles/contrib/social": [
                "goalgorilla/open_social"
            ],
            "html/profiles/contrib/{$name}": [
                "type:drupal-profile"
            ],
            "html/themes/contrib/{$name}": [
                "type:drupal-theme"
            ],
            "html/libraries/{$name}": [
                "type:drupal-library",
                "type:bower-asset",
                "type:npm-asset"
            ],
            "drush/contrib/{$name}": [
                "type:drupal-drush"
            ]
        },
        "enable-patching": true,
        "patchLevel": {
            "drupal/core": "-p2"
        }
    },
    "config": {
        "allow-plugins": {
            "composer/installers": true,
            "cweagans/composer-patches": true,
            "drupal/core-composer-scaffold": true,
            "oomphinc/composer-installers-extender": true,
            "zaporylie/composer-drupal-optimizations": true
        },
        "platform-check": false
    }
}

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.