1

I have a page view with exposed filters (4 checkboxes with ajax calling) which user can change.

I want to change default search, to searching only results which appears in this view.

How can I do that?

  • 1
    Are you trying to filter a list of Views results using exposed filters? I'm not understanding how you want to combine both... they're two separate things. "Search" searchers for content on the whole site, and Exposed Filters simply allows users to filter a list of Views Results. – Johnathan Elmore May 24 '12 at 13:53
  • Hi all and thanks for quick reply. I am getting views result and exposed filter works perfectly, it gave me good result. Next situation is: I want to add user an additional option to search this view, to search result which i am getting with exposed filters. I added search terms field in filter criteria, but when type something it searching only by title, and i wanted to search by title, body and location. These fields are already included my views. – miske May 24 '12 at 14:24
2

Views filter populate should help you with your issue. What you need to do is don't expose the Title, Body, and Location in the Filter Criteria of your view. Then add Populate filters and expose it and select Title, Body, and Location as your filters.

0

I think you want your view to display results ONLY when one of the checkboxes is checked. Am I right ?

If it's the case, in your view's Exposed Form section, you have to choose Input required as the Exposed form style.

  • Hi all and thanks for quick reply. I am getting views result and exposed filter works perfectly, it gave me good result. Next situation is: I want to add user an additional option to search this view, to search result which i am getting with exposed filters. I added search terms field in filter criteria, but when type something it searching only by title, and i wanted to search by title, body and location. These fields are already included my views. – miske May 24 '12 at 14:25
  • Searching on several fields cannot be achieved without code. Besides, it's another topic and you should open a new question for it. – Countzero May 24 '12 at 14:36
0

Click on the Global:Populate filters (exposed) Under Filter Criteria, make sure your body and location are checked.

Also, make sure your Operator are set correctly. For instance, set your Filter Criteria to something like this:

  • Content: Published (yes) AND
  • Content: Type (= your content)
  • AND
    • Content: Title (contains) OR
    • Content: body (contains) OR
    • Content: location (contains) OR
    • Global: Populate filters (exposed)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.