2

I am using Menu Token to create a link to a customized profile edit page that uses the url "user/%uid/edit". I've set the title of the link to "My Account" and although it works for my (admin) account, for the other roles the title is "Edit" instead (the default Drupal tab name for the /user menu item) and futhermore it does not appear to be the active trail. My thinking is that it's something to do with permissions since it works in one role but I can't seem to figure this out. Any help?

  • i'm not sure i understand what you say, is the title changing for different roles (like from "My Account" to "Edit").. – AjitS May 28 '12 at 14:05
  • Precisely that! – magtak May 28 '12 at 14:14
  • 1
    are you sure that they are same links (i.e. pointing to the same URL). To check whether it is an issue menu tokens, you could try using ME alias and replacing %uid from your URL by me. – AjitS May 28 '12 at 14:19
  • It's exactly the same link. When logged in as admin the title is what I've specified it to be, when not, it's Drupal's default "Edit". – magtak May 28 '12 at 14:28
  • i was not able to reproduce the problem on my Drupal 7 installation. can you please list out the modules you are using to achieve this? – AjitS May 29 '12 at 4:30
2

I think I got the answer.. just check for the snapshot. It seems you were using the wrong value of token in menu path. Use user/[user:uid]/edit instead.

snapshot

  • sadly, no. I am using exactly that :( – magtak May 29 '12 at 10:29
  • try using user/[current-user:uid]/edit – AjitS May 29 '12 at 10:44
  • same thing. i just went and overrode the title with code and fixed it that way. can't waste too much time on it. – magtak May 30 '12 at 14:57
  • ahh, ok. I'm not sure what caused the problem. I think you should report it as issue on drupal.org; have a thread running there and see if it helps solve the problem. – AjitS May 31 '12 at 7:06
1

Encountered the same problem using user/[current-user:uid]/edit and switched to [current-user:edit-url] which worked for me. The link title is now displaying as entered for all roles, not just admin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.