0

Hi I am working with a drupal 6 site and have a setup for this on my localhost the site is very huge and consists of almost 290 tables but the site is working super slow on my localhost specially the admin pages. It took almost 1hr to create a simple content type and 20-25 min to load module page, 30 min to enable/disable a module if not using drush about 10 mins using drush. This is becoming really time consuming for me to work like this. I have also configured the site performance but still no change. Rest of drupal 6/7 sites on my localhost are running fine.

  • having 290 tables should not be a criterion for slowness, additional info about the modules that have been installed and since when the slowness was observed might shed better light to the issue at hand. – optimusprime619 May 29 '12 at 12:51
  • I dont know enough, but my guys at work rely on caching - groups.drupal.org/node/21897. Specifically boost + OPCache to improve performance. Hope that helps! – Robbase May 29 '12 at 12:58
  • There a number of module that have been used for this site with about 30 custom modules. Besides it uses contributed modules like IMCE, Panels, Node Import, Lightbox2, devel,google analytics and many more. But this site is running slow on my system only its working better on others. – Somya Gupta May 29 '12 at 12:59
  • 1
    Your acceptance rate is quite low. Maybe you should consider accepting answers from your previous posts and upvoting those that were relevant. This way, the help you received will help others. See this awesome faq for more juicy details on how this community operates. Cheers! – stefgosselin May 29 '12 at 15:08
2

Profile it; it's on your local box, so it can be done. Until you do that it's a bad guessing game. What all contributes to drupal page execution time?

0

On which plateform are you running your website ? maybe you need to run things like memcached and APC, this really improves drupal performances. Therefore try to see if you have tables with lots of lines, like search_index table which can be growing up as the cron executes... Also if you are behind a proxy be sure to unable any modules that tries to get stuff from the net, this causes the admin to be very slow as every request that not passing through the proxy would stand by until a timeout to come... (like 30s) see Update status behind a proxy ...and sorry for my bad english ;)

  • Hi I am using apache server I have already enabled php apc it has enhanced the speed a bit but still the site is too slow to handle – Somya Gupta Jun 2 '12 at 4:13
0

3 tips: 1. install x-cache, PHP OP-code caching is very efficient for Drupal, especially for Drupal 7 but in Drupal 6 site will run much faster. I've optimized it a bit for my needs but only installing and enabling this Apache module with default settings should be OK 2. Apache settings - default are in most cases not efficient (are efficient for static HTML pages - not for very extendable CMS) set KeepAlive to max 3 seconds, you may also disable it at all

I've also set on my PC small limit of Apache server processes which may be run at one time, but if not many users access to your site an once (ie. installation for testing only), this should not be a problem

Not the answer you're looking for? Browse other questions tagged or ask your own question.