1

I have recently decided to move one of the sites to another hosting provider, and now started to receive this 500 error when submitting changes to admin/modules. The new hosting has different environment where all sites might have their core and contributed modules connected to the central repository; now, in admin/modules all 850 local repository modules can be seen as they were in sites/all/modules. In server logs this error reflect as:

mod_fcgid: stderr: PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 87437 bytes) in /opt/drupal7/includes/cache.inc on line 463, referer: admin/modules

mod_fcgid: stderr: PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 71 bytes) in /opt/drupal7/includes/form.inc on line 1820

mod_fcgid: stderr: PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 8208 bytes) in /opt/drupal7/modules/field/field.crud.inc on line 711, referer: admin/modules?render=overlay

mod_fcgid: stderr: PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 32 bytes) in /opt/drupal7/includes/file.inc on line 200, referer: admin/modules

The site has a 128 MB memory limit; it is more than on previous hosting, but now some of the enabled modules (like OpenLayers) sometime also issue memory errors (like those above, but on site they work without any 500 errors).

What can be the reason of this errors? Is there any additional information that can help find what to fix?

2

You need to check your PHP memory limit on php.ini.
If you use Linux, go to /etc/php.ini to find it out.

  • I'v already tried it before posting the question, the memory limit is set to 128 mb – ijujym Jun 4 '12 at 10:04
  • 850modules,maybe you need more memory – Wayn Liu Jun 5 '12 at 3:00
  • Yes, it was indeed an account quota issue, the upgrade solved it – ijujym Jun 6 '12 at 20:18
2

You can also set the PHP memory in settings.php file:

ini_set('memory_limit', '128M');
  • I'v already tried it before posting the question, the memory limit is set to 128 mb – ijujym Jun 4 '12 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.