I am trying to change the output in my view; the problem is that I cannot access the [URL] token to rewrite to <a href="[URL]">this is my link</a>.

It seems I can only access the [title] token. Do you have any idea?

  • To which Drupal version are you interested?
    – apaderno
    May 10, 2011 at 21:06

1 Answer 1


The tokens available when rewritting the output of a field correspond to the values of the other fields you have selected in the view. They must also be above the field you are rewritting in the field order.

In order to get the URL, you should add a node path (or link to node) above your current field and mark it as "hide from display".

The token will now be available!

PS - If you want to link to the node's url, you can always just select the option to display the field as a link to its node.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.