0

All of a sudden, for no reason (favorite kind of problem) Scanner stopped working. I can access the configuration at /admin/config/search/settings but trying load the scanner at admin/content/scanner fatal errors:

Fatal error: require_once() [function.require]: 
Failed opening required '/public_html/sites/all/modules/scanner/node.admin.inc'
(include_path='.:/usr/lib/php:/usr/local/lib/php') in 
/home/moondev/public_html/includes/menu.inc on line 514

Notice the path is wrong where it's trying to load node.admin.inc

Scanner used to work as expected so I suppose either an update changed something or a conflict with another module (or it's settings) is happening.

Anybody experience something similar before, where a core include is trying to be loaded from the wrong path?

  • Drupal 7.14 Scanner 7.x-1.x-dev – Merrick Jun 4 '12 at 22:47
  • Also just noticed drupal.org/project/scanner hasn't been worked on in quite a while... – Merrick Jun 4 '12 at 22:51
  • It's almost definitely something to do with the hook_menu() implementation in the scanner module...I know it's the 'go to' answer, but have you tried clearing the cache and running cron? – Clive Jun 4 '12 at 22:56
  • Yes, but I like the simplicity, so I'll do it again to double check ;) It's weird how it was working previously too. – Merrick Jun 4 '12 at 23:06
  • 1
    I've taken over maintainership of Scanner. This should not effect the latest version. – fizk Oct 17 '15 at 11:18
1

Turns out to be a conflict with Administration Views (7.x-1.0-alpha1).

Disable admin views & functionality is restored. Not sure where the blame is yet because I haven't pinpointed the conflict. But it does make sense at face value because admin views replaces the /admin/content and scanner is located at admin/content/scanner

  • Remember to accept your own answer, so other users know you found a solution, and the question is not bumped to the front page, causing other uses to check your question thinking it needs to be answered. :) – kiamlaluno Aug 11 '12 at 16:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.