1

I have been trying this for a while without success. After installing the OpenLayers module in drupal 7.14 and trying to configure it i get the following error:

Cannot establish a connection to the server:

I have tried all permutations including downloading the openlayers library in the local machine, giving it a local path in a number of different ways.

The second error that is seen suggests that i am installing an incorrect version of the openlayers library when in fact i have been installing the recommended version i.e. version 2.11.

It has been a frustrating experience getting Openlayers, Geoserver , PostGIS and Drupal 7 working together on Windows 7. The number of combinations are many and there are many issues that are difficult to solve if you are not a webmaster.

1

There is a patch for the '?q' URL problem which occurs using openlayers-7.x-2.0-beta1, apply the openlayers-fix-marker-lang-path-1404912-3.patch (http://drupal.org/node/1404912) it should fix this for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.