10

I am using Node clone.
The administration part of the module works 100%. I can edit the settings, but the clone tab that should appear beside the other node related tabs (edit, devel...) does not appear.

Has anyone out there used this module and could help me?

  • having the same problem currently ... i saw that in drupal 7 node clone cannot use any content type for cloning : / for example file cck... More infos at /admin/config/content/clone – user1977 Jul 13 '11 at 15:12
8

I have enabled Node clone on a Drupal 7 site. The cloning capability appears as an action link at the beginning of the node content on the View tab, not as a separate tab. The link text is "Clone content". The actual HTML is:

<ul class="action-links"><li><a href="/node/34/clone">Clone content</a></li>

I'm using a clean Zen subtheme. Perhaps your theme is preventing the action links from appearing?

| improve this answer | |
  • Dan, sorry for validating your answer ages after I asked it (almost 6 years? Oh, gee). A new comment just appeared on the thread and I finally realized I hadn't approved your answer. Well, better late than never. Abraços! – Marcos Buarque Jan 2 '17 at 20:25
3

This is an older question, but for anyone out there looking for a solution to this for Drupal 7, the simplest way is to install the Node Clone Tab module, and it will appear as a tab next to View, Edit, Devel, etc.

| improve this answer | |
  • 1
    Thank you for sharing, I had no idea about this module... Having a tab there seems like the most logical/ordinary approach to node cloning. – Marcos Buarque Feb 3 '16 at 17:36
2

Sounds like a permission issue, this module defines 2 new permissions, have you set them for the users you want?

| improve this answer | |
  • 1
    Hi, thanks for the answer. Actually, I am logged in as admin and I should have access to all the module features... – Marcos Buarque May 12 '11 at 12:23
2

I experienced the same problem, the "Clone Content" link wasn't displayed on my node preview page because I had a custom built theme that only output certain fields for each node. Try switching to another theme and see I that solves your problem.

The reason why the link didn't appear was because I had removed the following code from the page.tpl.php

 <?php 
 if ($action_links): ?>
    <ul class="action-links"><?php print render($action_links); ?></ul>
 <?php endif; ?>

My suggestion is to check your page.tpl.php file so that the above statement really exists. If it doesn't simply copy the code into your template. note remember to empty your cache after doing so.

| improve this answer | |
1

If you have Views installed, and /admin/content has been set up to have editable views, you can add the "Clone" link to the view. Just click the gear (that appears when you hover over the view) and choose "Edit view". Then (next to the word "FIELDS") click "add". Select "Content: Clone link" from the list of fields to add. Don't bother with a (column header) label, and you can leave all other settings at the defaults. Save the view and you should have a "Clone" link next to every node (that you haven't excluded in the configuration for Node Clone).

| improve this answer | |
1

I meet the same problem on Drupal 8 with a Bootstrap theme. Inspired by Dan Halbert's answer above

The cloning capability appears as an action link at the beginning of the node content on the View tab, not as a separate tab. The link text is "Clone content".

I turn on the action link (Primary admin action, under Structure > Block layout) and it works exactly.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.