1

Can an anyone help me.I am getting the following error while running my drupal 7 application

Fatal error: Cannot redeclare function views_views_plugins() (previously declared in /var/www/vhosts/cibi.hq.k.grp/newsite/sites/all/modules/views/includes/plugins.inc:15). If this code worked without the Zend Optimizer+, please set zend_optimizerplus.dups_fix=1 in your ini file in /var/www/vhosts/cibi.hq.k.grp/newsite/sites/all/modules/ctools/ctools.module on line 113

  • Did you notice this part of the error message: If this code worked without the Zend Optimizer+, please set zend_optimizerplus.dups_fix=1 in your ini file – BetaRide Jun 27 '12 at 15:54
  • FWIW, I don't have zend_optimizerplus.dups_fix=1 set on any of y servers running Drupal 7 with views. Clear your cache. I think your registry may be corrupted. – mpdonadio Jun 27 '12 at 16:07
0

The very same thing happened to me after transferring my website to another hosting company.

You must run update.php.

Since I was logged out, the way I resolved this is as follows: I typed in the url box www.example.com/update.php (www.example.com being your site's name. If it's on your local machine, I guess it is something like localhost/update.php.)

If your settings.php file is properly configured, you should get an access denied message.

In that case, go to the directory (sites/default) and open the settings.php file. Look for the line $update_free_access = FALSE; and change it to TRUE.

Run update.php again. You will find a link at the bottom of the result page sending you to the front page. Click on it and your site is back in business. :)

CAUTION. Very important: Go to your settings.php file again and change the TRUE back to FALSE.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.