0

(this question has been asked on Stackoverflow so I apologise for the repitition)

Firstly some background,..

IVe started a new job as PHP developer with a company that hosts 2 Drupal (6.x) sites.

While I have years of experience in PHP, Drupal ( and indeed off the shelf content management systems in general ) is a new one on me. Still, there is loads of documentation and its not rocket science, so no problems there.

The server environment is IIS (live server 7.0, locally 7.5) IIS is a totally new beast to me too, so it adds to teh learning curve.

I have successfully gotten a clean install of Drupal (7.x) to run locally, so I know the server is up and running correctly

The problem happens when I try to pull down the live site. I have replicated the database locally, and I know that it is connecting, however when I try to run the local site I get a blank page with the following source c ode:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"> 
<html lang="en"> 
  <head> 
    <?include '_inc_head_common.tpl.php';?> 
  </head> 

  <body id="body"> 

      <?include '_inc_header.tpl.php';?> 
      <?include '_inc_content_3col.tpl.php';?> 
      <?include '_inc_footer.tpl.php';?> 
  </body> 
</html> 

So it seems that it is getting to a point and no further..

has anyone encountered this before or could someone point me in the direction that I should be looking at?

Thanks

Kevin

  • did you clear all cache and run dabase update? – chefnelone Jun 14 '12 at 9:32
  • I cleared the cache by emptying the cache tables in the databse. How do I run database update? – Kevin Bradshaw Jun 14 '12 at 9:43
  • load this url: localhost/yourSiteFolder/update.php. You should also run the status report to check up any error: localhost/yourSiteFolder/admin/reports/status – chefnelone Jun 14 '12 at 9:51
  • have you turned on Error reporting ? – GoodSp33d Jun 14 '12 at 10:04
0

Seems like you are using PHP shorthand. Can you change it to a proper and see if that helps? Please see if the path is correct since drupal is using relative path (base_url, base_path). Also please update the $base_url in the settings.php if you have.

| improve this answer | |
  • The issue was that in my php.ini file 'short_open_tag' was set to off. changing this to 'on' resolved my issue. Accepting your answer for putting me on the right track. Can you please clarify how to check my path? thanks – Kevin Bradshaw Jun 14 '12 at 10:37
  • First check if the $base_url in settings.php file (sites/default/settings.php) is not commented. If disabled its fine. It's just that it will be used as a base path of Drupal file system if turned on. You can verify that if you CSS, JS and images is loading correctly. – user8012 Jun 14 '12 at 10:51
0

As your don't have the Gui error reporting running, you can check it out through the database with this query:

SELECT * FROM watchdog ORDER BY wid DESC LIMIT 2;

Also place this in the very beginning of your index.php:

error_reporting(E_ALL);
ini_set('display_errors', TRUE);
ini_set('display_startup_errors', TRUE);

Good luck!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.