0

I've successfully installed and configured the Wysiwyg module with CKeditor. However, it keeps disappearing. First it disappeared when I enabled another module (cannot remember which, but thankfully it wasn't necessary so I could disable it again). I was just lucky to figure that out.

But now it disappeared again, and I don't know what happened this time. I didn't install any new modules.

Any ideas why this is happening? Is the wysiwyg module too unstable to use? If so, what's the alternative?

EDIT:

The issue keeps coming back, but I have discovered something new: if I disable a module (and optionally enable it again), apparently pretty much any module, then the wysiwyg editor appears again(!)

So it seems any change in the modules installed brings the editor back. I have only tested this in localhost, if that has anything to do with it.

bumped to the homepage by Community 2 days ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • It works quite well for us. We use it on a lot of websites. Do you see any Javascript errors on the pages that WYSIWYG won't load? It usually happens when there's a javascript error which stops the execution of the script that loads the editor. An alternative is the CKEditor module that doesn't use WYSIWYG module. – Beebee Jun 15 '12 at 8:12
  • Ok, well it worked for me as well. Now I actually got it working again by experimenting a bit, and this time disabling lightbox2 did the trick. Apparently there are many conflicts with wysiwyg. I just wish I knew which they are... – Anders Svensson Jun 15 '12 at 10:07
  • We have a lot of websites using WYSIWYG with a combination of Lightbox2 as well as lots of other contrib modules. We never noticed this issue. Weird. Would be nice to know what exactly caused your issue when you figure it out. – Beebee Jun 15 '12 at 11:03
  • Yeah, well, I have no idea. It just disappeared again, and all I had done this time was to create a new content type...! Yes, it is really weird... – Anders Svensson Jun 15 '12 at 11:06
  • Sounds like you have an underlying issue on your Drupal installation, not really connected with WYSIWYG but at least it's affecting it. – Beebee Jun 15 '12 at 11:07
0

go to modules and find jQuery Update module, and put it to version 1.8 That should fix the issue.

  • that's not really an answer. wysiwyg works fine on 1.5 as well. you should check the console log on chrome or firefox to see what the exact problem is. most probably this happens when you use multiple 3rd party jquery plugins. checking the console log helps alot. – shrish Feb 27 '15 at 9:16
0

The issue might be with ckEditor library. Try to remove this library from sites/all/libraries and upload the new one from here :

http://download.cksource.com/CKEditor/CKEditor/CKEditor%203.6.5/ckeditor_3.6.5.zip.

For reference : https://www.drupal.org/node/1839322enter link description here

0

No guarantee it will help, but I think it's worth trying: increase your php memory limit (eg add like 25 to 50% of it, just to try) and try again.

Since you're experiencing problems because of "enabling" modules, and since they seem to temporary disappear if you disable some of them again, it could well be that you've reached a memory limit that causes these kinds of related problems ...

0

This problem appears to be coming from bad aggregation of JavaScripts. I had a similar experience where the bundled JavaScript contained an occasional syntax error (can be caused by any other module, not only wysiwyg)

While clearing the cache (which also happend if you enable/disable a module), the JavaScript will be rebuilt.

I particulary noticed this with the advagg module.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.