5

The number of shorctuts is limited to 7 (second row)

enter image description here

When I add an 8th shortcut it is in the disabled section

enter image description here

How do I change that?

4 Answers 4

7

The maximum number of shortcuts is defined in shortcut_max_slots(), which just returns a variable:

return variable_get('shortcut_max_slots', 7);

So all you need to do is change that variable to something larger than 7. You can use the devel variable editor to do it, or just run the following code from somewhere:

variable_set('shortcut_max_slots', 10);
3
  • Simply change modules/shortcut/shortcut.admin.inc, line 16
    – Ray Hulha
    May 16, 2013 at 7:52
  • @RayHulha Hacking core when there's a trivial override like in the above example isn't the best advice
    – Clive
    May 16, 2013 at 8:03
  • Good point, although I consider it a bug fix ;-)
    – Ray Hulha
    May 16, 2013 at 13:58
1

You can also refer to this Drupal core issue thread: Remove the default limit of 7 shortcuts per shortcut set. There's a patch there to completely remove the limit.

1

The easiest way to update the shortcut_max_slots variable is actually through drush (assuming that you are using it). The command is:

drush vset shortcut_max_slots number

For example, I did:

drush vset shortcut_max_slots 15
1

You can also do this by adding the following code to your settings.php in sites/default/files/ to increase max number of shortcuts to a preferred value.

/* Configuration option to set max number of shortcuts on the shortcut bar */ $conf['shortcut_max_slots'] = 20;

source - https://api.drupal.org/comment/34883#comment-34883

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.