4

I'm having trouble inserting images via TinyMCE (I've also installed WYSIWYG). I can insert images into an article just fine and all looks as it should while I'm editing an article, but if I preview or save the article and then view it, the image doesn't show up, instead I see:

[img]/sites/default/files/myimage.png[/img]

I've tried making the content with full html, and I've installed the media module and selected an option under text formats that is supposed to convert media tags into html.

What am I missing?

  • Have you checked if the "Limit allowed HTML tags" checkbox is un-ticked under /admin/config/content/formats/full_html? – Volker Jun 23 '12 at 14:40
  • How are you embedding the images? If they should be stored on your drupal installation consider using this modules: drupal.org/project/imce, drupal.org/project/imce_wysiwyg – BetaRide Jun 23 '12 at 15:28
  • @Volker - yes, the box is unchecked – Kyle Jun 23 '12 at 19:06
  • @BetaRide - Thanks for the suggestion, I've installed the Bridge module but it did not fix the issue. I've also just noticed that text formatting is not working either – Kyle Jun 23 '12 at 19:07
2

Disabling the BBCode option in my TinyMCE Wysiwyg profile worked for me.

1

Use the Bbcode module to convert the bbcode to HTML tags. Here is a quote about it (from the module's project page):

... adds a BBCode filter to Drupal. This allows you to use HTML-like tags as an alternative to HTML itself for adding markup to your posts. BBCode is easier to use than HTML and helps to prevent malicious users from disrupting your site's formatting.

See the help screen of the module (or the code) for information on which tags and variants are supported. This implementation is not necessarily the same as the original BBCode implementation.

Note that this filter also recognizes and converts URLs and email addresses to links automatically.

The quicktags module can be used in conjunction with this module to provide a BBCode formatting bar above all text areas.

  • I was also looking for a solution, and after installing bbcode, everything whent smooth :) – Vic Aug 20 '12 at 13:42
0

I ended up using CKEditor instead of TinyMCE; it worked like a charm.

0

Disabling that BBcode was the key for me. I have been searching for some time for this problem and came across everything from permissions to .htaccess and setting.php.

Thank you localstatic for you are the hero of the day if not the week.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.