0

When I remove html.tpl.php file, I get this error:

Warning: include(/home/xxxx/public_html/sites/all/themes/cgame/html.tpl.php) [function.include]: failed to open stream: No such file or directory in theme_render_template() (line 1413 of /home/xxxx/public_html/includes/theme.inc).
Warning: include() [function.include]: Failed opening '/home/xxxx/public_html/sites/all/themes/cgame/html.tpl.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in theme_render_template() (line 1413 of /home/xxxx/public_html/includes/theme.inc).

How can I remove this file to force drupal use core html.tpl.php file?

  • 3
    Clear the caches, that should do it – Clive Jun 26 '12 at 14:05
  • When I remove html.tpl.php file I get WSOD and I even can not access to clear cache page – Mohammad Ali Akbari Jun 26 '12 at 17:36
  • Which core html.tpl.php file are you actually talking about? – Chapabu Jun 26 '12 at 21:04
  • I need remove sites/all/themes/cgame/html.tpl.php and use modules/system/html.tpl.php instead – Mohammad Ali Akbari Jun 27 '12 at 4:11
1

considering White Screen of Death problem you should clear cache from DB or change default theme to another theme so can clear cache from drupal admin interface, if you have access to DB first solution is easier and fast but in case you don't, use second one :

1.truncate cache table:

TRUNCATE cache;

2.set another default theme so you can clear cache from admin/config/development/performance page. you can simply edit settings.php and add $conf['theme_default']= "new_theme_name" variable to change default theme or edit variables table in DB and set theme_default name to another name, sample SQL:

UPDATE variable SET value='s:7:"garland"' WHERE name = 'theme_default';

then while this new theme is set you can clear cache as usual and then fallback to old theme without problem.

| improve this answer | |
  • ;) I was looking for something like theme registry editor to simply remove html.tpl.php from default theme, but there isn't – Mohammad Ali Akbari Jun 27 '12 at 4:17
1

Simply clear the caches either on /admin/config/development/performance or via drush cc all if you've configured drush.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.