I have unchecked the sitename in admin/build/themes/settings but all of the titles of pages are still showing the site name.

I am not sure why this happens. Is there any other way to remove it?

I have installed the Page Title module, and in admin/settings/page-title I have the page title set as [page-title] for that particular page, not as [page-title] | [site-name].

  • It's going to sound like a schoolboy error, but have you cleared the caches? Also - is it the front page that's causing issues? If I remember correctly you have to set the front page page-title on a different page.
    – Chapabu
    Jul 2, 2012 at 9:46
  • What version of the module did you install?
    – apaderno
    Jul 2, 2012 at 10:00
  • version : drupal 6 Jul 2, 2012 at 10:19
  • Its not the front page which causes this error.... @ Chapabu Jul 2, 2012 at 10:21
  • That is not the module version. Are you using version 6.x-2.7, the development snapshot, or any other version?
    – apaderno
    Jul 2, 2012 at 14:35

2 Answers 2


Try the Page Title module. Here is a quote about it (from the module's project page):

The word "title" is a bit overloaded. Every piece of content in Drupal has a title, and so does every page. The page title is the one found in the HTML head inside the tag. It is also used on SERPs (Search Engine Result Pages) and can greatly enhance your websites SEO (Search Engine Optimization).

This module gives you granular control over the page title. You can specify patterns for how the title should be structured and, on content creation pages, specify the page title separately to the content's title.

  • Ya page title module have been enabled .. but still where should i make changes to remove the site name from my page title??? Jul 2, 2012 at 8:36

You could create a Panel (or a mini-panel) that includes the page element "Site name" and place it wherever you want in that Panel, and than Toggle off the Site's name in the Themes' settings (only after you have created that panel, or mini-panel).

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.