1

I have uploaded my drupal commerce files. I get the message that my credential are wrong. I am just not sure whaht info they want for the

In order for Drupal to work, and to continue with the installation process, you must resolve all issues reported below. For more help with configuring your database server, see the installation handbook. If you are unsure what any of this means you should probably contact your hosting provider.

Failed to connect to your database server. The server reports the following message: SQLSTATE[28000] [1045] Access denied for user 'admin'@'localhost' (using password: YES).

  • Is the database server running?
  • Does the database exist, and have you entered the correct database name?
  • Have you entered the correct username and password?
  • Have you entered the correct database hostname?

I though I knew all of this information. I am running on my web host using admin as username. Any help would be greatly appreciated.

  • 2
    Are you sure of the database username is admin? – svetlio Jul 4 '12 at 6:59
3

Change the settings in your settings.php file. For remote server you should change this like below;

$databases = array (
  'default' => array(
    'default' => array (
      'database' => 'name of database uploaded on remote server',
      'username' => 'root',
      'password' => 'root',
      'host' => 'localhost',
      'port' => '',
      'driver' => 'mysql',
      'prefix' => '',
    ),
  ),
);
  • 'username' and 'password' are for the remote server
  • 'host' is the hostname of the hosting server
2

You need to get the credentials for your database server form your webhost. This is usually a MYSQL database server, this tends to have a different username and password from the admin username and password

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.